x11-misc/xautolock: Version 2.2_p5_p2
authorJeroen Roovers <jer@gentoo.org>
Tue, 15 Oct 2019 10:01:41 +0000 (12:01 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 15 Oct 2019 10:01:53 +0000 (12:01 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/xautolock/Manifest
x11-misc/xautolock/xautolock-2.2_p5_p2.ebuild [new file with mode: 0644]

index acfef7bf2a208b9829103e7c097de7e2e0f56211..3a0121027a6100875166acea3c0be2778afce06e 100644 (file)
@@ -1,2 +1,3 @@
 DIST xautolock-2.2.tgz 35288 BLAKE2B 0cd709470002d7a6852a41a56e9f6b540405e172f30e3243a93b578e362f117a3ddd3b6ff15e653eb5466d15e7ff1d5505c19ccfd27d6e7d6ccae4c826a689ac SHA512 5f9dcc25cda706610e77a74235c4b421ca3a833d154b1a269057f0774579e1c6ec36fe0e5be5fadd6942ce8c1640a760f891397586b162e6024b524635153d04
 DIST xautolock_2.2-5.1.debian.tar.xz 5828 BLAKE2B 6a664d30b993986e70af853c037738da0576ca5ee3a0452329d4dffd3132899d1099b5bcc5bbf68ab688240b388396335b0d5227b140a74deca313112d0088cd SHA512 315f27518b89fa6633e3ce157423cd271f3db3b797fc59febc35aa8b33379bd6eda55ac9c7ccdf996c2d9d50bb6bef3b15add84b39236ace425740238de77e59
+DIST xautolock_2.2-5.2.debian.tar.xz 6216 BLAKE2B bda8c7a084e8975d268d626cc5aa02c87c7e6b0ae92351375f298cde4fabd8e48a0578c7c4bf32a280e2ecf13d82b7dcd73a874863616c0f9812ea98ffbe27e8 SHA512 807c9c7da51b16ed3a6600732f8d3b606d2f6c628238df0e6d975ea176ddce3d0e321779b19662f693ed1811b288ddae1b45228c0939e0728c122c1a2e556391
diff --git a/x11-misc/xautolock/xautolock-2.2_p5_p2.ebuild b/x11-misc/xautolock/xautolock-2.2_p5_p2.ebuild
new file mode 100644 (file)
index 0000000..4a586f5
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="An automatic X screen-locker/screen-saver"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/screensavers/"
+
+DEB_REV_MAJ="$(ver_cut 4)"
+DEB_REV_MIN="$(ver_cut 6)"
+DEB_REVISION="${DEB_REV_MAJ/p}.${DEB_REV_MIN/p}"
+SRC_URI="
+       ${HOMEPAGE}/${P/_p*/}.tgz
+       mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEB_REVISION}.debian.tar.xz
+"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+       x11-libs/libXScrnSaver
+"
+DEPEND="
+       ${RDEPEND}
+       app-text/rman
+       x11-base/xorg-proto
+       x11-misc/imake
+"
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+       eapply "${WORKDIR}"/debian/patches/*.patch
+       default
+}
+
+src_configure() {
+       xmkmf || die
+}
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               CDEBUGFLAGS="${CFLAGS}" \
+               EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install () {
+       dobin xautolock
+       newman xautolock.man xautolock.1
+       dodoc Changelog Readme Todo
+}