acct-user/scponly: added user for scponly.
authorHank Leininger <hlein@korelogic.com>
Tue, 18 Feb 2020 20:52:33 +0000 (13:52 -0700)
committerUlrich Müller <ulm@gentoo.org>
Wed, 19 Feb 2020 20:15:31 +0000 (21:15 +0100)
Signed-off-by: Hank Leininger <hlein@korelogic.com>
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
acct-user/scponly/metadata.xml [new file with mode: 0644]
acct-user/scponly/scponly-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/scponly/metadata.xml b/acct-user/scponly/metadata.xml
new file mode 100644 (file)
index 0000000..1685347
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>hlein@korelogic.com</email>
+               <name>Hank Leininger</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/scponly/scponly-0.ebuild b/acct-user/scponly/scponly-0.ebuild
new file mode 100644 (file)
index 0000000..86b78a5
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="user for chrooted scponly"
+ACCT_USER_ID=239
+ACCT_USER_GROUPS=( scponly )
+# Not a typo.  scponly uses the trailing // to identify the chroot dir.
+ACCT_USER_HOME=/var/chroot/scponly//
+ACCT_USER_HOME_OWNER=root:root
+
+acct-user_add_deps