dev-python/testtools: Add python3.5 support
authorJustin Lecher <jlec@gentoo.org>
Sun, 11 Oct 2015 10:19:49 +0000 (12:19 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 11 Oct 2015 11:24:29 +0000 (13:24 +0200)
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/testtools/metadata.xml
dev-python/testtools/testtools-1.8.0-r1.ebuild [new file with mode: 0644]

index a8d7eada5bca24a542d9eb83913dc160193a3488..248ba18d1bfd54b930a57959aeab74ba4664666b 100644 (file)
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
   <herd>bazaar</herd>
diff --git a/dev-python/testtools/testtools-1.8.0-r1.ebuild b/dev-python/testtools/testtools-1.8.0-r1.ebuild
new file mode 100644 (file)
index 0000000..6243aeb
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the Python standard library unit testing framework"
+HOMEPAGE="https://github.com/testing-cabal/testtools"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+       dev-python/extras[${PYTHON_USEDEP}]
+       dev-python/mimeparse[${PYTHON_USEDEP}]
+       >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+       >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
+       dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( doc/_build/html/. )
+
+       distutils-r1_python_install_all
+}