app-dicts/edictionary: EAPI bump, bug 605728
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 8 Apr 2017 21:35:09 +0000 (23:35 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 8 Apr 2017 21:36:48 +0000 (23:36 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

app-dicts/edictionary/edictionary-2.6-r1.ebuild [new file with mode: 0644]

diff --git a/app-dicts/edictionary/edictionary-2.6-r1.ebuild b/app-dicts/edictionary/edictionary-2.6-r1.ebuild
new file mode 100644 (file)
index 0000000..a0ae02b
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="edict"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command line dictionary and thesaurus"
+HOMEPAGE="http://edictionary.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+       make prefix="${ED}/usr/bin" install
+       dodoc Changelog ReleaseNotes README TODO
+}