dev-python/gevent: version bump to 1.2.2
authorZac Medico <zmedico@gentoo.org>
Wed, 29 Nov 2017 20:07:16 +0000 (12:07 -0800)
committerZac Medico <zmedico@gentoo.org>
Wed, 29 Nov 2017 20:13:47 +0000 (12:13 -0800)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

dev-python/gevent/Manifest
dev-python/gevent/gevent-1.2.2.ebuild [new file with mode: 0644]

index f691bc2a5164018461efd3154770d4178a6044f6..f04ee6d9ec21aa4a1a72951680644ef58ada7947 100644 (file)
@@ -1,2 +1,3 @@
 DIST gevent-1.0.1.tar.gz 1455636 SHA256 4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43 SHA512 4790e06b49536ad15856cf551c7ad4d717be2ceda8bc7d39fc35a0132d21f302e033f3294da426be4f6c0476554163776e5ffd82d89962503a720c453ff96461 WHIRLPOOL a1d552f89e9d3db1720fd0db1dbfb6ffc7ed4db87ee5816e5c44843f3c5bba9afbfc21ab2cfcf5bfc84ea70fea3caf6f8fbdbc2807c868b27105bce7e58d6290
 DIST gevent-1.2.1.tar.gz 2808619 BLAKE2B 2e3c15adb33401012951f0f93fe7f17c1c7597bb4021a4a9ebc7ecae390565d9892bb2fffe9cdac4f7e207d97d50da5d335ed8e42070d67d6be617cf955eb0b4 SHA512 22740e8e114869c1f53bcfd6796226927a3a726d4fd49d104b947f0c97546c7490eabea98b4492db794e21d26d0aee85f1e40b01d386a47063b042a719e61726
+DIST gevent-1.2.2.tar.gz 3108671 BLAKE2B f80df00f58ae2f65aa7f65fc9eac5cbf63a0084f24ccebc71ba9bafba72cd48fff2e7d0b1d8de7939dc669d7708e120fc14077cc845fe3ce212d6a80a42b5158 SHA512 1e2dd544cffea62ee32de2e4066b3f4c121058a1211b89da281ec3882f3763217fe2d346ce38b66e27df9f59cfe05bb137d1608a681dd10eaf06a33dc22f531c
diff --git a/dev-python/gevent/gevent-1.2.2.ebuild b/dev-python/gevent/gevent-1.2.2.ebuild
new file mode 100644 (file)
index 0000000..bb595bf
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# http://www.gevent.org/whatsnew_1_1.html#broader-platform-support
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.python.org/pypi/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+       >=dev-libs/libev-4.23
+       >=net-dns/c-ares-1.12
+       >=dev-python/greenlet-0.4.10
+       virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+       export LIBEV_EMBED="false"
+       export CARES_EMBED="false"
+       export EMBED="false"
+
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       cd src/greentest || die
+
+       GEVENT_RESOLVER=thread \
+               "${PYTHON}" testrunner.py --config known_failures.py || die
+       GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
+               "${PYTHON}" testrunner.py --config known_failures.py \
+               --ignore tests_that_dont_use_resolver.txt || die
+       GEVENT_FILE=thread \
+               "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
+}
+
+python_install_all() {
+       local DOCS=( AUTHORS README.rst )
+       use doc && local HTML_DOCS=( doc/_build/html/. )
+       use examples && dodoc -r examples
+
+       distutils-r1_python_install_all
+}