dev-python/astunparse: bump 1.6.3
authorJason Zaman <perfinion@gentoo.org>
Fri, 15 May 2020 01:53:29 +0000 (09:53 +0800)
committerJason Zaman <perfinion@gentoo.org>
Sat, 16 May 2020 00:52:26 +0000 (08:52 +0800)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
dev-python/astunparse/Manifest
dev-python/astunparse/astunparse-1.6.3.ebuild [new file with mode: 0644]

index ad72dea5442b00b7619cdd006a069cbe7a68c981..2d28afb76e9ffa941208b12ece784a715e33ace1 100644 (file)
@@ -1 +1,2 @@
 DIST astunparse-1.6.2.tar.gz 16339 BLAKE2B d35d63b8313718c1d873d55b7da824465be9b4bc9e486ff82dac7db2df5185f8a59bfb283844d7108927b04ee02879fe921c87f9da8bd87c157341e6022b40cc SHA512 1e344354481dab7345d8790791e15e2ce733b8985839972a1771b97adebbfc2b42c8fb258ea36f245baed553d3b8e5007872d6559ebcc5ef1eb6f6c6a5d66c81
+DIST astunparse-1.6.3.tar.gz 18290 BLAKE2B d7e6fa3ba58c6e112eb84720832890f4515b1c4ed420587565cdff37da893c07eefd0b9eb00795a3eb08bf56834d65150298a6be65e524b0c267c38e6f9c20d1 SHA512 12e99b32524e551494d3053a57aeb646bca8a96a9aa17b0737e6dace6c11874e2e7633d82197cacc0b55622bea637030344ab45c8db57ef244bd63663799d2e9
diff --git a/dev-python/astunparse/astunparse-1.6.3.ebuild b/dev-python/astunparse/astunparse-1.6.3.ebuild
new file mode 100644 (file)
index 0000000..2fb67c4
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Astun parser for python"
+HOMEPAGE="https://github.com/simonpercivall/astunparse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+       >=dev-python/wheel-0.23.0[${PYTHON_USEDEP}]
+"
+PATCHES=(
+       "${FILESDIR}/astunparse-1.6.2-tests.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+       distutils-r1_python_install_all
+       dodoc *.rst
+}