dev-python/pypy3: Drop 7.1.1
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 07:49:58 +0000 (08:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:03:37 +0000 (09:03 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pypy3/Manifest
dev-python/pypy3/files/7.0.0_all_distutils_cxx.patch [deleted file]
dev-python/pypy3/pypy3-7.1.1.ebuild [deleted file]

index 1c2085f148ff6c09292211ab3475c6e42fe3c82a..4fa9943404f41902be661c77c5f66a9296a50ac1 100644 (file)
@@ -1,2 +1 @@
-DIST pypy3.6-v7.1.1-src.tar.bz2 23171982 BLAKE2B be43528bc6f3e02d146016a4969bd8c7a9e880a3bd3b77f441aac6d22ef67700f71e0171ec000066bd2c0bd506db64af69d6b75b59a92222dd0353ee70e6629b SHA512 17e78f9c7080d597a6283d8e8247d1ca78f09a14ff221db8c3d90d255b5befc73102b317ca34a80979e544d5ee72f3e5e649f89d185a085f4cc15012da4d0473
 DIST pypy3.6-v7.2.0-src.tar.bz2 21850076 BLAKE2B 756ea3034fe8971c979ec83c9cbfac55a680f3ef03b276475aa4318f3480ae5ede609b8413412df64db553a33979670498b1f97184f3b57406619c9db7f01127 SHA512 bcbb53062a473d504bcc082cf6286f6169c83d1f38d22c4d7c4e46ddc32bca9d91e71194637e6650db5bec02b29fe262b22fe236d627b6bc3e6e0c59c66c07cc
diff --git a/dev-python/pypy3/files/7.0.0_all_distutils_cxx.patch b/dev-python/pypy3/files/7.0.0_all_distutils_cxx.patch
deleted file mode 100644 (file)
index a9099e5..0000000
+++ /dev/null
@@ -1,347 +0,0 @@
-From 5c396fb8b644e5de82d9b54cdb088ea673e16e14 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 25 Apr 2017 17:42:33 +0200
-Subject: [PATCH] Fancy distutils C++ support, rebased for PyPy3.5/7.0.0
-
-https://bugs.python.org/issue1222585
----
- lib-python/3/_osx_support.py                | 10 ++--
- lib-python/3/distutils/cygwinccompiler.py   | 21 ++++++--
- lib-python/3/distutils/sysconfig_cpython.py | 25 ++++++++--
- lib-python/3/distutils/sysconfig_pypy.py    | 34 ++++++++++---
- lib-python/3/distutils/unixccompiler.py     | 54 +++++++++++----------
- lib_pypy/_sysconfigdata.py                  |  1 +
- 6 files changed, 100 insertions(+), 45 deletions(-)
-
-diff --git a/lib-python/3/_osx_support.py b/lib-python/3/_osx_support.py
-index 13fcd8b8d2..0525be1cbc 100644
---- a/lib-python/3/_osx_support.py
-+++ b/lib-python/3/_osx_support.py
-@@ -14,13 +14,13 @@ __all__ = [
- # configuration variables that may contain universal build flags,
- # like "-arch" or "-isdkroot", that may need customization for
- # the user environment
--_UNIVERSAL_CONFIG_VARS = ('CFLAGS', 'LDFLAGS', 'CPPFLAGS', 'BASECFLAGS',
--                            'BLDSHARED', 'LDSHARED', 'CC', 'CXX',
--                            'PY_CFLAGS', 'PY_LDFLAGS', 'PY_CPPFLAGS',
--                            'PY_CORE_CFLAGS')
-+_UNIVERSAL_CONFIG_VARS = ('CFLAGS', 'CXXFLAGS', 'LDFLAGS', 'CPPFLAGS',
-+                          'BASECFLAGS', 'BLDSHARED', 'LDSHARED', 'LDCXXSHARED',
-+                          'CC', 'CXX', 'PY_CFLAGS', 'PY_LDFLAGS',
-+                          'PY_CPPFLAGS', 'PY_CORE_CFLAGS')
- # configuration variables that may contain compiler calls
--_COMPILER_CONFIG_VARS = ('BLDSHARED', 'LDSHARED', 'CC', 'CXX')
-+_COMPILER_CONFIG_VARS = ('BLDSHARED', 'LDSHARED', 'LDCXXSHARED', 'CC', 'CXX')
- # prefix added to original configuration variable names
- _INITPRE = '_OSX_SUPPORT_INITIAL_'
-diff --git a/lib-python/3/distutils/cygwinccompiler.py b/lib-python/3/distutils/cygwinccompiler.py
-index c879646c0f..a6157fbd5f 100644
---- a/lib-python/3/distutils/cygwinccompiler.py
-+++ b/lib-python/3/distutils/cygwinccompiler.py
-@@ -125,8 +125,10 @@ class CygwinCCompiler(UnixCCompiler):
-         # dllwrap 2.10.90 is buggy
-         if self.ld_version >= "2.10.90":
-             self.linker_dll = "gcc"
-+            self.linker_dll_cxx = "g++"
-         else:
-             self.linker_dll = "dllwrap"
-+            self.linker_dll_cxx = "dllwrap"
-         # ld_version >= "2.13" support -shared so use it instead of
-         # -mdll -static
-@@ -140,9 +142,13 @@ class CygwinCCompiler(UnixCCompiler):
-         self.set_executables(compiler='gcc -mcygwin -O -Wall',
-                              compiler_so='gcc -mcygwin -mdll -O -Wall',
-                              compiler_cxx='g++ -mcygwin -O -Wall',
-+                             compiler_so_cxx='g++ -mcygwin -mdll -O -Wall',
-                              linker_exe='gcc -mcygwin',
-                              linker_so=('%s -mcygwin %s' %
--                                        (self.linker_dll, shared_option)))
-+                                        (self.linker_dll, shared_option)),
-+                             linker_exe_cxx='g++ -mcygwin',
-+                             linker_so_cxx=('%s -mcygwin %s' %
-+                                            (self.linker_dll_cxx, shared_option)))
-         # cygwin and mingw32 need different sets of libraries
-         if self.gcc_version == "2.91.57":
-@@ -166,8 +172,12 @@ class CygwinCCompiler(UnixCCompiler):
-                 raise CompileError(msg)
-         else: # for other files use the C-compiler
-             try:
--                self.spawn(self.compiler_so + cc_args + [src, '-o', obj] +
--                           extra_postargs)
-+                if self.detect_language(src) == 'c++':
-+                    self.spawn(self.compiler_so_cxx + cc_args + [src, '-o', obj] +
-+                               extra_postargs)
-+                else:
-+                    self.spawn(self.compiler_so + cc_args + [src, '-o', obj] +
-+                               extra_postargs)
-             except DistutilsExecError as msg:
-                 raise CompileError(msg)
-@@ -302,9 +312,14 @@ class Mingw32CCompiler(CygwinCCompiler):
-         self.set_executables(compiler='gcc -O -Wall',
-                              compiler_so='gcc -mdll -O -Wall',
-                              compiler_cxx='g++ -O -Wall',
-+                             compiler_so_cxx='g++ -mdll -O -Wall',
-                              linker_exe='gcc',
-                              linker_so='%s %s %s'
-                                         % (self.linker_dll, shared_option,
-+                                           entry_point),
-+                             linker_exe_cxx='g++',
-+                             linker_so_cxx='%s %s %s'
-+                                        % (self.linker_dll_cxx, shared_option,
-                                            entry_point))
-         # Maybe we should also append -mthreads, but then the finished
-         # dlls need another dll (mingwm10.dll see Mingw32 docs)
-diff --git a/lib-python/3/distutils/sysconfig_cpython.py b/lib-python/3/distutils/sysconfig_cpython.py
-index 573724ddd7..0a04f33a86 100644
---- a/lib-python/3/distutils/sysconfig_cpython.py
-+++ b/lib-python/3/distutils/sysconfig_cpython.py
-@@ -173,9 +173,12 @@ def customize_compiler(compiler):
-                 _osx_support.customize_compiler(_config_vars)
-                 _config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
--        (cc, cxx, opt, cflags, ccshared, ldshared, shlib_suffix, ar, ar_flags) = \
--            get_config_vars('CC', 'CXX', 'OPT', 'CFLAGS',
--                            'CCSHARED', 'LDSHARED', 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
-+        (cc, cxx, ccshared, ldshared, ldcxxshared, shlib_suffix, ar, ar_flags) = \
-+            get_config_vars('CC', 'CXX', 'CCSHARED', 'LDSHARED', 'LDCXXSHARED',
-+                            'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
-+
-+        cflags = ''
-+        cxxflags = ''
-         if 'CC' in os.environ:
-             newcc = os.environ['CC']
-@@ -190,19 +193,27 @@ def customize_compiler(compiler):
-             cxx = os.environ['CXX']
-         if 'LDSHARED' in os.environ:
-             ldshared = os.environ['LDSHARED']
-+        if 'LDCXXSHARED' in os.environ:
-+            ldcxxshared = os.environ['LDCXXSHARED']
-         if 'CPP' in os.environ:
-             cpp = os.environ['CPP']
-         else:
-             cpp = cc + " -E"           # not always
-         if 'LDFLAGS' in os.environ:
-             ldshared = ldshared + ' ' + os.environ['LDFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['LDFLAGS']
-         if 'CFLAGS' in os.environ:
--            cflags = opt + ' ' + os.environ['CFLAGS']
-+            cflags = os.environ['CFLAGS']
-             ldshared = ldshared + ' ' + os.environ['CFLAGS']
-+        if 'CXXFLAGS' in os.environ:
-+            cxxflags = os.environ['CXXFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['CXXFLAGS']
-         if 'CPPFLAGS' in os.environ:
-             cpp = cpp + ' ' + os.environ['CPPFLAGS']
-             cflags = cflags + ' ' + os.environ['CPPFLAGS']
-+            cxxflags = cxxflags + ' ' + os.environ['CPPFLAGS']
-             ldshared = ldshared + ' ' + os.environ['CPPFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['CPPFLAGS']
-         if 'AR' in os.environ:
-             ar = os.environ['AR']
-         if 'ARFLAGS' in os.environ:
-@@ -211,13 +222,17 @@ def customize_compiler(compiler):
-             archiver = ar + ' ' + ar_flags
-         cc_cmd = cc + ' ' + cflags
-+        cxx_cmd = cxx + ' ' + cxxflags
-         compiler.set_executables(
-             preprocessor=cpp,
-             compiler=cc_cmd,
-             compiler_so=cc_cmd + ' ' + ccshared,
--            compiler_cxx=cxx,
-+            compiler_cxx=cxx_cmd,
-+            compiler_so_cxx=cxx_cmd + ' ' + ccshared,
-             linker_so=ldshared,
-             linker_exe=cc,
-+            linker_so_cxx=ldcxxshared,
-+            linker_exe_cxx=cxx,
-             archiver=archiver)
-         compiler.shared_lib_extension = shlib_suffix
-diff --git a/lib-python/3/distutils/sysconfig_pypy.py b/lib-python/3/distutils/sysconfig_pypy.py
-index bf1748e300..70dfd72a1a 100644
---- a/lib-python/3/distutils/sysconfig_pypy.py
-+++ b/lib-python/3/distutils/sysconfig_pypy.py
-@@ -145,36 +145,52 @@ def customize_compiler(compiler):
-                 _osx_support.customize_compiler(_config_vars)
-                 _config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
--        (cc, cxx, opt, cflags, ccshared, ldshared, shlib_suffix, ar, ar_flags) = \
--            get_config_vars('CC', 'CXX', 'OPT', 'CFLAGS',
--                            'CCSHARED', 'LDSHARED', 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
-+        (cc, cxx, ccshared, ldshared, ldcxxshared, shlib_suffix, ar, ar_flags) = \
-+            get_config_vars('CC', 'CXX', 'CCSHARED', 'LDSHARED', 'LDCXXSHARED',
-+                            'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
-+
-+        cflags = ''
-+        cxxflags = ''
-         if 'CC' in os.environ:
-             newcc = os.environ['CC']
--            if (sys.platform == 'darwin'
-+            if (True
-                     and 'LDSHARED' not in os.environ
-                     and ldshared.startswith(cc)):
-                 # On OS X, if CC is overridden, use that as the default
-                 #       command for LDSHARED as well
-+                # Gentoo: s/OS X/every system/
-                 ldshared = newcc + ldshared[len(cc):]
-             cc = newcc
-         if 'CXX' in os.environ:
--            cxx = os.environ['CXX']
-+            newcxx = os.environ['CXX']
-+            if ('LDCXXSHARED' not in os.environ
-+                    and ldcxxshared.startswith(cxx)):
-+                ldcxxshared = newcxx + ldcxxshared[len(cxx):]
-+            cxx = newcxx
-         if 'LDSHARED' in os.environ:
-             ldshared = os.environ['LDSHARED']
-+        if 'LDCXXSHARED' in os.environ:
-+            ldcxxshared = os.environ['LDCXXSHARED']
-         if 'CPP' in os.environ:
-             cpp = os.environ['CPP']
-         else:
-             cpp = cc + " -E"           # not always
-         if 'LDFLAGS' in os.environ:
-             ldshared = ldshared + ' ' + os.environ['LDFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['LDFLAGS']
-         if 'CFLAGS' in os.environ:
--            cflags = opt + ' ' + os.environ['CFLAGS']
-+            cflags = os.environ['CFLAGS']
-             ldshared = ldshared + ' ' + os.environ['CFLAGS']
-+        if 'CXXFLAGS' in os.environ:
-+            cxxflags = os.environ['CXXFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['CXXFLAGS']
-         if 'CPPFLAGS' in os.environ:
-             cpp = cpp + ' ' + os.environ['CPPFLAGS']
-             cflags = cflags + ' ' + os.environ['CPPFLAGS']
-+            cxxflags = cxxflags + ' ' + os.environ['CPPFLAGS']
-             ldshared = ldshared + ' ' + os.environ['CPPFLAGS']
-+            ldcxxshared = ldcxxshared + ' ' + os.environ['CPPFLAGS']
-         if 'AR' in os.environ:
-             ar = os.environ['AR']
-         if 'ARFLAGS' in os.environ:
-@@ -183,13 +199,17 @@ def customize_compiler(compiler):
-             archiver = ar + ' ' + ar_flags
-         cc_cmd = cc + ' ' + cflags
-+        cxx_cmd = cxx + ' ' + cxxflags
-         compiler.set_executables(
-             preprocessor=cpp,
-             compiler=cc_cmd,
-             compiler_so=cc_cmd + ' ' + ccshared,
--            compiler_cxx=cxx,
-+            compiler_cxx=cxx_cmd,
-+            compiler_so_cxx=cxx_cmd + ' ' + ccshared,
-             linker_so=ldshared,
-             linker_exe=cc,
-+            linker_so_cxx=ldcxxshared,
-+            linker_exe_cxx=cxx,
-             archiver=archiver)
-         compiler.shared_lib_extension = shlib_suffix
-diff --git a/lib-python/3/distutils/unixccompiler.py b/lib-python/3/distutils/unixccompiler.py
-index 32030ed150..1db3d5498b 100644
---- a/lib-python/3/distutils/unixccompiler.py
-+++ b/lib-python/3/distutils/unixccompiler.py
-@@ -52,14 +52,17 @@ class UnixCCompiler(CCompiler):
-     # are pretty generic; they will probably have to be set by an outsider
-     # (eg. using information discovered by the sysconfig about building
-     # Python extensions).
--    executables = {'preprocessor' : None,
--                   'compiler'     : ["cc"],
--                   'compiler_so'  : ["cc"],
--                   'compiler_cxx' : ["c++"],  # pypy: changed, 'cc' is bogus
--                   'linker_so'    : ["cc", "-shared"],
--                   'linker_exe'   : ["cc"],
--                   'archiver'     : ["ar", "-cr"],
--                   'ranlib'       : None,
-+    executables = {'preprocessor'    : None,
-+                   'compiler'        : ["cc"],
-+                   'compiler_so'     : ["cc"],
-+                   'compiler_cxx'    : ["c++"],
-+                   'compiler_so_cxx' : ["c++"],
-+                   'linker_so'       : ["cc", "-shared"],
-+                   'linker_exe'      : ["cc"],
-+                   'linker_so_cxx'   : ["c++", "-shared"],
-+                   'linker_exe_cxx'  : ["c++"],
-+                   'archiver'        : ["ar", "-cr"],
-+                   'ranlib'          : None,
-                   }
-     if sys.platform[:6] == "darwin":
-@@ -125,12 +128,19 @@ class UnixCCompiler(CCompiler):
-     def _compile(self, obj, src, ext, cc_args, extra_postargs, pp_opts):
-         compiler_so = self.compiler_so
-+        compiler_so_cxx = self.compiler_so_cxx
-         if sys.platform == 'darwin':
-             compiler_so = _osx_support.compiler_fixup(compiler_so,
-                                                     cc_args + extra_postargs)
-+            compiler_so_cxx = _osx_support.compiler_fixup(compiler_so_cxx,
-+                                                    cc_args + extra_postargs)
-         try:
--            self.spawn(compiler_so + cc_args + [src, '-o', obj] +
--                       extra_postargs)
-+            if self.detect_language(src) == 'c++':
-+                self.spawn(compiler_so_cxx + cc_args + [src, '-o', obj] +
-+                           extra_postargs)
-+            else:
-+                self.spawn(compiler_so + cc_args + [src, '-o', obj] +
-+                           extra_postargs)
-         except DistutilsExecError as msg:
-             raise CompileError(msg)
-@@ -188,22 +198,16 @@ class UnixCCompiler(CCompiler):
-                 ld_args.extend(extra_postargs)
-             self.mkpath(os.path.dirname(output_filename))
-             try:
--                if target_desc == CCompiler.EXECUTABLE:
--                    linker = self.linker_exe[:]
-+                if target_lang == "c++":
-+                    if target_desc == CCompiler.EXECUTABLE:
-+                        linker = self.linker_exe_cxx[:]
-+                    else:
-+                        linker = self.linker_so_cxx[:]
-                 else:
--                    linker = self.linker_so[:]
--                if target_lang == "c++" and self.compiler_cxx:
--                    # skip over environment variable settings if /usr/bin/env
--                    # is used to set up the linker's environment.
--                    # This is needed on OSX. Note: this assumes that the
--                    # normal and C++ compiler have the same environment
--                    # settings.
--                    i = 0
--                    if os.path.basename(linker[0]) == "env":
--                        i = 1
--                        while '=' in linker[i]:
--                            i += 1
--                    linker[i] = self.compiler_cxx[i]
-+                    if target_desc == CCompiler.EXECUTABLE:
-+                        linker = self.linker_exe[:]
-+                    else:
-+                        linker = self.linker_so[:]
-                 if sys.platform == 'darwin':
-                     linker = _osx_support.compiler_fixup(linker, ld_args)
-diff --git a/lib_pypy/_sysconfigdata.py b/lib_pypy/_sysconfigdata.py
-index 2ceafe80bf..ee3f802c41 100644
---- a/lib_pypy/_sysconfigdata.py
-+++ b/lib_pypy/_sysconfigdata.py
-@@ -15,6 +15,7 @@ build_time_vars = {
-     'CFLAGS': "-DNDEBUG -O2",
-     'CCSHARED': "-fPIC",
-     'LDSHARED': "cc -pthread -shared",
-+    'LDCXXSHARED': "c++ -pthread -shared",
-     'EXT_SUFFIX': so_ext,
-     'SHLIB_SUFFIX': ".so",
-     'AR': "ar",
--- 
-2.20.1
-
diff --git a/dev-python/pypy3/pypy3-7.1.1.ebuild b/dev-python/pypy3/pypy3-7.1.1.ebuild
deleted file mode 100644 (file)
index 344f0da..0000000
+++ /dev/null
@@ -1,271 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy3 needs to be built using python 2
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs pax-utils python-any-r1 toolchain-funcs
-
-MY_P=pypy3.6-v${PV}
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python (3.6) language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2"
-
-LICENSE="MIT"
-# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
-SLOT="0/71-py36"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 cpu_flags_x86_sse2 gdbm +jit libressl low-memory ncurses
-       sandbox sqlite tk"
-
-RDEPEND=">=sys-libs/zlib-1.1.3:0=
-       virtual/libffi:0=
-       virtual/libintl:0=
-       dev-libs/expat:0=
-       !libressl? ( dev-libs/openssl:0=[-bindist] )
-       libressl? ( dev-libs/libressl:0= )
-       bzip2? ( app-arch/bzip2:0= )
-       gdbm? ( sys-libs/gdbm:0= )
-       ncurses? ( sys-libs/ncurses:0= )
-       sqlite? ( dev-db/sqlite:3= )
-       tk? (
-               dev-lang/tk:0=
-               dev-tcltk/tix:0=
-       )
-       !dev-python/pypy3-bin:0"
-DEPEND="${RDEPEND}
-       low-memory? ( virtual/pypy )
-       !low-memory? (
-               || (
-                       virtual/pypy
-                       (
-                               dev-lang/python:2.7
-                               dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
-                       )
-               )
-       )"
-
-S="${WORKDIR}/${MY_P}-src"
-
-check_env() {
-       if use low-memory; then
-               CHECKREQS_MEMORY="1750M"
-               use amd64 && CHECKREQS_MEMORY="3500M"
-       else
-               CHECKREQS_MEMORY="3G"
-               use amd64 && CHECKREQS_MEMORY="6G"
-       fi
-
-       check-reqs_pkg_pretend
-}
-
-pkg_pretend() {
-       [[ ${MERGE_TYPE} != binary ]] && check_env
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != binary ]]; then
-               check_env
-
-               # unset to allow forcing pypy below :)
-               use low-memory && local EPYTHON=
-               if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
-                       einfo "Using PyPy to perform the translation."
-                       local EPYTHON=pypy
-               else
-                       einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
-                       einfo "recommends using PyPy for that. If you wish to do so, please install"
-                       einfo "virtual/pypy and ensure that EPYTHON variable is unset."
-               fi
-
-               python-any-r1_pkg_setup
-       fi
-}
-
-src_prepare() {
-       eapply "${FILESDIR}/7.0.0-gentoo-path.patch"
-       eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
-       eapply "${FILESDIR}"/5.9.0-shared-lib.patch     # 517002
-       eapply "${FILESDIR}"/7.0.0_all_distutils_cxx.patch
-
-       sed -e "s^@EPREFIX@^${EPREFIX}^" \
-               -i lib-python/3/distutils/command/install.py || die
-
-       # apply CPython stdlib patches
-       pushd lib-python/3 > /dev/null || die
-       eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch
-       popd > /dev/null || die
-
-       eapply_user
-}
-
-src_configure() {
-       tc-export CC
-
-       local jit_backend
-       if use jit; then
-               jit_backend='--jit-backend='
-
-               # We only need the explicit sse2 switch for x86.
-               # On other arches we can rely on autodetection which uses
-               # compiler macros. Plus, --jit-backend= doesn't accept all
-               # the modern values...
-
-               if use x86; then
-                       if use cpu_flags_x86_sse2; then
-                               jit_backend+=x86
-                       else
-                               jit_backend+=x86-without-sse2
-                       fi
-               else
-                       jit_backend+=auto
-               fi
-       fi
-
-       local args=(
-               --shared
-               $(usex jit -Ojit -O2)
-               $(usex sandbox --sandbox '')
-
-               ${jit_backend}
-
-               pypy/goal/targetpypystandalone
-       )
-
-       # Avoid linking against libraries disabled by use flags
-       local opts=(
-               bzip2:bz2
-               ncurses:_minimal_curses
-       )
-
-       local opt
-       for opt in "${opts[@]}"; do
-               local flag=${opt%:*}
-               local mod=${opt#*:}
-
-               args+=(
-                       $(usex ${flag} --withmod --withoutmod)-${mod}
-               )
-       done
-
-       local interp=( "${PYTHON}" )
-       if use low-memory; then
-               interp=( env PYPY_GC_MAX_DELTA=200MB
-                       "${PYTHON}" --jit loop_longevity=300 )
-       fi
-
-       # translate into the C sources
-       # we're going to make them ourselves since otherwise pypy does not
-       # free up the unneeded memory before spawning the compiler
-       set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
-       echo -e "\033[1m${@}\033[0m"
-       "${@}" || die "translation failed"
-}
-
-src_compile() {
-       emake -C "${T}"/usession*-0/testing_1
-
-       # copy back to make sys.prefix happy
-       cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
-       pax-mark m pypy3-c libpypy3-c.so
-
-       einfo "Generating caches and CFFI modules ..."
-
-       # Generate Grammar and PatternGrammar pickles.
-       ./pypy3-c -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
-               || die "Generation of Grammar and PatternGrammar pickles failed"
-
-       # Generate cffi modules
-       # Please keep in sync with pypy/tool/build_cffi_imports.py!
-#cffi_build_scripts = {
-#    "sqlite3": "_sqlite3_build.py",
-#    "audioop": "_audioop_build.py",
-#    "tk": "_tkinter/tklib_build.py",
-#    "curses": "_curses_build.py" if sys.platform != "win32" else None,
-#    "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
-#    "_gdbm": "_gdbm_build.py"  if sys.platform != "win32" else None,
-#    "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
-#    "resource": "_resource_build.py" if sys.platform != "win32" else None,
-#    "lzma": "_lzma_build.py",
-#    "_decimal": "_decimal_build.py",
-#    "_ssl": "_ssl_build.py",
-#    "_blake2": "_blake2/_blake2_build.py",
-#    "_sha3": "_sha3/_sha3_build.py",
-       cffi_targets=( blake2/_blake2 sha3/_sha3 ssl
-               audioop syslog pwdgrp resource lzma decimal )
-       use gdbm && cffi_targets+=( gdbm )
-       use ncurses && cffi_targets+=( curses )
-       use sqlite && cffi_targets+=( sqlite3 )
-       use tk && cffi_targets+=( tkinter/tklib )
-
-       einfo "Please disregard the import errors during CFFI cache generation."
-       einfo "They come from modules not built yet."
-
-       local t
-       # all modules except tkinter output to .
-       # tkinter outputs to the correct dir ...
-       cd lib_pypy || die
-       for t in "${cffi_targets[@]}"; do
-               # tkinter doesn't work via -m
-               ../pypy3-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
-       done
-
-       # Cleanup temporary objects
-       find -name "_cffi_*.[co]" -delete || die
-       find -type d -empty -delete || die
-}
-
-src_test() {
-       # (unset)
-       local -x PYTHONDONTWRITEBYTECODE=
-
-       # Test runner requires Python 2 too. However, it spawns PyPy3
-       # internally so that we end up testing the correct interpreter.
-       "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python || die
-}
-
-src_install() {
-       local dest=/usr/lib/pypy3.6
-       einfo "Installing PyPy ..."
-       exeinto "${dest}"
-       doexe pypy3-c libpypy3-c.so
-       pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
-       insinto "${dest}"
-       # preserve mtimes to avoid obsoleting caches
-       insopts -p
-       doins -r include lib_pypy lib-python
-       dosym ../lib/pypy3.6/pypy3-c /usr/bin/pypy3
-       dodoc README.rst
-
-       if ! use gdbm; then
-               rm -r "${ED%/}${dest}"/lib_pypy/_gdbm* || die
-       fi
-       if ! use sqlite; then
-               rm -r "${ED%/}${dest}"/lib-python/*3/sqlite3 \
-                       "${ED%/}${dest}"/lib_pypy/_sqlite3* \
-                       "${ED%/}${dest}"/lib-python/*3/test/test_sqlite.py || die
-       fi
-       if ! use tk; then
-               rm -r "${ED%/}${dest}"/lib-python/*3/{idlelib,tkinter} \
-                       "${ED%/}${dest}"/lib_pypy/_tkinter \
-                       "${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
-       fi
-
-       einfo "Generating caches and byte-compiling ..."
-
-       local -x PYTHON=${ED%/}${dest}/pypy3-c
-       # we can't use eclass function since PyPy is dumb and always gives
-       # paths relative to the interpreter
-       local PYTHON_SITEDIR=${EPREFIX}/usr/lib/pypy3.6/site-packages
-       python_export pypy3 EPYTHON
-
-       echo "EPYTHON='${EPYTHON}'" > epython.py || die
-       python_domodule epython.py
-
-       einfo "Byte-compiling Python standard library..."
-
-       # compile the installed modules
-       python_optimize "${ED%/}${dest}"
-}