net-libs/nodejs: use snapshot || --without-node-snapshot
authorJeroen Roovers <jer@gentoo.org>
Sat, 25 Jan 2020 10:38:47 +0000 (11:38 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 25 Jan 2020 10:48:07 +0000 (11:48 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Closes: https://bugs.gentoo.org/682946
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nodejs/nodejs-12.14.1-r1.ebuild [moved from net-libs/nodejs/nodejs-12.14.1.ebuild with 99% similarity]
net-libs/nodejs/nodejs-13.6.0-r1.ebuild [moved from net-libs/nodejs/nodejs-13.6.0.ebuild with 99% similarity]
net-libs/nodejs/nodejs-13.7.0-r1.ebuild [moved from net-libs/nodejs/nodejs-13.7.0.ebuild with 99% similarity]
net-libs/nodejs/nodejs-99999999.ebuild

similarity index 99%
rename from net-libs/nodejs/nodejs-12.14.1.ebuild
rename to net-libs/nodejs/nodejs-12.14.1-r1.ebuild
index a9a42fa11ba48b4a62ac0995883c56a685903ded..b8a749a17459fc35a385ccf5d1b54afe2a5c5152 100644 (file)
@@ -105,7 +105,7 @@ src_configure() {
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
+       use snapshot || myconf+=( --without-node-snapshot )
        use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
 
        local myarch=""
similarity index 99%
rename from net-libs/nodejs/nodejs-13.6.0.ebuild
rename to net-libs/nodejs/nodejs-13.6.0-r1.ebuild
index 3f434606d2fee58a309e3263524a41ecf49176e4..640cc3cc0b12c99fa5f7bb2be5fb7749b61a4efc 100644 (file)
@@ -103,7 +103,7 @@ src_configure() {
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
+       use snapshot || myconf+=( --without-node-snapshot )
        use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
 
        local myarch=""
similarity index 99%
rename from net-libs/nodejs/nodejs-13.7.0.ebuild
rename to net-libs/nodejs/nodejs-13.7.0-r1.ebuild
index 2f83361825eb42f393ed3a70819652a29f5f5692..35f1444b8a498f4cf2d9e6a4531d04fb7a1e93f8 100644 (file)
@@ -103,7 +103,7 @@ src_configure() {
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
+       use snapshot || myconf+=( --without-node-snapshot )
        use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
 
        local myarch=""
index 5c9388651deda4c43c655dc2d985a40e0c7c76ff..aad8df6897f2acd299c2e1e34d690208180e3a71 100644 (file)
@@ -100,7 +100,7 @@ src_configure() {
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
+       use snapshot || myconf+=( --without-node-snapshot )
        use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
 
        local myarch=""