Remove old versions
authorTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 21:51:03 +0000 (21:51 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 21:51:03 +0000 (21:51 +0000)
Package-Manager: portage-2.1.2_rc2-r1

games-emulation/fceultra/fceultra-0.81-r1.ebuild [deleted file]
games-emulation/fceultra/fceultra-0.97.5.ebuild [deleted file]
games-emulation/fceultra/fceultra-0.98.10.ebuild [deleted file]
games-emulation/fceultra/files/0.97.5-joystick.patch [deleted file]
games-emulation/fceultra/files/digest-fceultra-0.81-r1 [deleted file]
games-emulation/fceultra/files/digest-fceultra-0.97.5 [deleted file]
games-emulation/fceultra/files/digest-fceultra-0.98.10 [deleted file]

diff --git a/games-emulation/fceultra/fceultra-0.81-r1.ebuild b/games-emulation/fceultra/fceultra-0.81-r1.ebuild
deleted file mode 100644 (file)
index 76d1cc5..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.81-r1.ebuild,v 1.10 2006/04/13 20:32:39 wolf31o2 Exp $
-
-inherit toolchain-funcs games
-
-MY_P=fceu
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A portable NES/Famicom Emulator"
-HOMEPAGE="http://fceultra.sourceforge.net/"
-SRC_URI="http://fceultra.sourceforge.net/dev/${MY_P}${PV//.}src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -ppc"
-IUSE="sdl svga"
-
-DEPEND="svga? ( media-libs/svgalib )
-       sdl? ( media-libs/libsdl )"
-
-pkg_setup() {
-       games_pkg_setup
-       if [ `gcc-major-version` == 3 ] && [ `gcc-minor-version` == 2 ] && [ ${ARCH} == "x86" ] ; then
-               eerror "Do not use gcc 3.2.x to compile the source code"
-               eerror "on 80x86/IA32 platforms. It has a code generation"
-               eerror "bug in it that will cause FCE Ultra to not work."
-               die "cant compile on x86 with gcc-3.2.x"
-       fi
-
-       use sdl && return 0
-       use svga && return 0
-
-       eerror "You must have 'sdl' or 'svga' in your USE variable"
-       die "unable to build SVGA or SDL versions"
-}
-
-src_compile() {
-       mv Makefile.base Makefile.orig
-       sed -e "s:\${TFLAGS}:\${TFLAGS} ${CFLAGS}:" \
-               Makefile.orig > Makefile.base
-
-       if use sdl ; then
-               make -f Makefile.unixsdl || die "sdl make failed"
-               mv fceu fceu-sdl
-               make -f Makefile.unixsdl clean
-       fi
-       if use svga ; then
-               make -f Makefile.linuxvga || die "svga make failed"
-               mv fceu fceu-svga
-       fi
-}
-
-src_install() {
-       use sdl && dobin fceu-sdl
-       use svga && dobin fceu-svga
-       dodoc Documentation/{*,rel/readme-linux.txt}
-       prepgamesdirs
-}
diff --git a/games-emulation/fceultra/fceultra-0.97.5.ebuild b/games-emulation/fceultra/fceultra-0.97.5.ebuild
deleted file mode 100644 (file)
index 9991553..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.97.5.ebuild,v 1.7 2005/05/17 18:01:01 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="A portable NES/Famicom emulator"
-HOMEPAGE="http://fceultra.sourceforge.net/"
-SRC_URI="http://xodnizel.net/fceultra/downloads/fceu-${PV}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86"
-
-IUSE="sdl svga"
-
-# Because of code generation bugs, FCEUltra now depends on a version
-# of gcc greater than or equal to GCC 3.2.2.
-RDEPEND="|| (
-               svga? ( media-libs/svgalib )
-               sdl? ( media-libs/libsdl )
-               media-libs/libsdl
-       )
-       >=sys-devel/gcc-3.2.2
-       sys-libs/zlib"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
-
-S=${WORKDIR}/fceu
-
-src_unpack() {
-       unpack ${A}
-
-       cd ${S}
-       epatch "${FILESDIR}/${PV}-joystick.patch"
-       sed -i \
-               -e 's:-mcpu=i686 -O2::' \
-               -e 's:-fomit-frame-pointer::' \
-               Makefile.linuxvga Makefile.unixsdl Makefile.unixsdl.gtk || \
-                       die "sed Makefiles failed"
-       sed -i \
-               -e "s:\${TFLAGS}:\${TFLAGS} ${CFLAGS}:" Makefile.base || \
-                       die "sed Makefile.base failed"
-}
-
-src_compile() {
-       if use sdl || ! use svga; then
-               emake -f Makefile.unixsdl || die "sdl make failed"
-               mv fceu fceu-sdl
-               make -f Makefile.unixsdl clean
-       fi
-       if use svga ; then
-               emake -f Makefile.linuxvga || die "svga make failed"
-               mv fceu fceu-svga
-       fi
-}
-
-src_install() {
-       if use sdl || ! use svga; then
-               dogamesbin fceu-sdl     || die "dogamesbin failed (sdl)"
-               doman Documentation/*.6 || die "doman failed (sdl)"
-       fi
-       if use svga ; then
-               dogamesbin fceu-svga    || die "dogamesbin failed (svga)"
-               doman Documentation/*.6 || die "doman failed (svga)"
-       fi
-       dodoc Documentation/{*.txt,AUTHORS,FAQ,README,TODO} || die "dodoc failed"
-       cp -r Documentation/tech "${D}/usr/share/doc/${P}/" || die "cp failed"
-       find ${D}/usr/share/doc/${P}/tech -type f -exec gzip -9 \{\} \; || \
-               die "find failed"
-       dohtml Documentation/*                              || die "dohtml failed"
-       prepgamesdirs
-}
diff --git a/games-emulation/fceultra/fceultra-0.98.10.ebuild b/games-emulation/fceultra/fceultra-0.98.10.ebuild
deleted file mode 100644 (file)
index 1024501..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.98.10.ebuild,v 1.4 2004/07/01 11:13:59 eradicator Exp $
-
-inherit eutils games
-
-DESCRIPTION="A portable NES/Famicom emulator"
-HOMEPAGE="http://fceultra.sourceforge.net/"
-SRC_URI="http://fceultra.sourceforge.net/releases/fceu-${PV}.src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="opengl"
-
-RDEPEND="virtual/libc
-       >=media-libs/libsdl-1.2.0
-       opengl? ( virtual/opengl )
-       sys-libs/zlib"
-# Because of code generation bugs, FCEUltra now depends on a version
-# of gcc greater than or equal to GCC 3.2.2.
-DEPEND="${RDEPEND}
-       >=sys-devel/gcc-3.2.2"
-
-S="${WORKDIR}/fceu"
-
-src_compile() {
-       egamesconf \
-               --disable-dependency-tracking \
-               --without-gtk \
-               --disable-gtktest \
-               $(use_with opengl) || die
-       emake || die "emake failed"
-}
-
-src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
-       dodoc Documentation/*.txt AUTHORS README NEWS TODO ChangeLog
-       cp -r Documentation/tech "${D}/usr/share/doc/${PF}/" || die "cp failed"
-       prepalldocs
-       dohtml Documentation/*
-       prepgamesdirs
-}
diff --git a/games-emulation/fceultra/files/0.97.5-joystick.patch b/games-emulation/fceultra/files/0.97.5-joystick.patch
deleted file mode 100644 (file)
index 40bb745..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
---- drivers/cli/sdl-joystick.c.orig    2003-06-21 22:49:24.000000000 -0500
-+++ drivers/cli/sdl-joystick.c 2003-07-10 19:10:38.000000000 -0500
-@@ -143,20 +143,12 @@
- /* Configure a joystick axis. */
- void AConfig (int n, int a)
- {
--        Sint16 lastaxe[64];
--        int numaxes;
--        int axis;
-+      SDL_Event event;
-       WNoInput();
-         joyAMap[n][a] = a;
--        numaxes=SDL_JoystickNumAxes(jo[n]);
--        if(numaxes>64) numaxes=64;
--
--        for(axis=0;axis<numaxes;axis++)       /* Pre-load. */
--              lastaxe[axis]=SDL_JoystickGetAxis(jo[n], axis);
--
-       while (1)
-         {
-                 uint8 t;
-@@ -167,31 +159,26 @@
-                 }
-                 else
-                         break;
--               
--                SDL_JoystickUpdate();
--
--                for (axis=0;axis<numaxes;axis++) {
--                      if (abs((Sint32)SDL_JoystickGetAxis(jo[n],axis)-lastaxe[axis]) > 8192) {
--                                      joyAMap[n][a] = axis;
--                                      /* 4096 should be good enough to account for any jitter. */
--                                      while (abs((Sint32)SDL_JoystickGetAxis(jo[n],axis)-lastaxe[axis]) > 4096) {
--                                              SDL_JoystickUpdate();
--                                              SDL_Delay(50);
--                                              }
--                                        goto endaconfig;
--                      }
--                }
--                SDL_Delay(100);
--        }
--
--      endaconfig:
--      WNoInput();
-+      
-+              SDL_JoystickUpdate();
-+              if (SDL_PollEvent(&event) && (event.type == SDL_JOYAXISMOTION))
-+              {
-+                      // Make sure the joystick was moved by some significant amount
-+                      if ((event.jaxis.value < -3000) || (event.jaxis.value > 3000))
-+                      {
-+                              joyAMap[n][a] = event.jaxis.axis;
-+                              WNoInput();
-+                              return;
-+                      }
-+              }
-+      }
-       return;
- }
- /* Configure a joystick button. */
- void BConfig (int n, int b)
- {
-+      SDL_Event event;
-       WNoInput();
-       joyBMap[n][b] = 0;
-       while (1)
-@@ -206,23 +193,15 @@
-                       break;
-               
-               SDL_JoystickUpdate();
-+
-+              if (SDL_PollEvent(&event) && event.type == SDL_JOYBUTTONDOWN)
-               {
--                       int buttons;
--                       for (buttons = SDL_JoystickNumButtons(jo[n])-1;buttons >= 0;buttons--) {
--                               if (SDL_JoystickGetButton(jo[n],buttons)) {
--                                       joyBMap[n][b] = buttons+1;
--                                       while (SDL_JoystickGetButton(jo[n], buttons)) {
--                                               SDL_JoystickUpdate();
--                                               SDL_Delay(50);
--                                       }
--                                       goto endbconfig;
--                               }
--                       }
-+                      joyBMap[n][b] = event.jbutton.button+1;
-+                      WNoInput();
-+                      return;
-               }
--              SDL_Delay(100);
-       }
--      endbconfig:
-       WNoInput();
-       return;
- }
diff --git a/games-emulation/fceultra/files/digest-fceultra-0.81-r1 b/games-emulation/fceultra/files/digest-fceultra-0.81-r1
deleted file mode 100644 (file)
index 8722963..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1dcfc1199a2dad906ddb771f89f50ddf fceu081src.tar.gz 424700
diff --git a/games-emulation/fceultra/files/digest-fceultra-0.97.5 b/games-emulation/fceultra/files/digest-fceultra-0.97.5
deleted file mode 100644 (file)
index 4c1952e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a3a3732d58ddb66ae9a78b2bac1d6a1f fceu-0.97.5.src.tar.gz 551337
diff --git a/games-emulation/fceultra/files/digest-fceultra-0.98.10 b/games-emulation/fceultra/files/digest-fceultra-0.98.10
deleted file mode 100644 (file)
index efa533d..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e0b396955b3ef4c7e4b5cc518cdec39f fceu-0.98.10.src.tar.bz2 559750