dev-libs/rinutils: 0.4.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 4 Apr 2020 00:59:22 +0000 (02:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 4 Apr 2020 00:59:22 +0000 (02:59 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/rinutils/Manifest
dev-libs/rinutils/rinutils-0.4.0.ebuild [new file with mode: 0644]

index f9c4ac2cdc72e533081104bcfa567498c553af7a..eb2bee2ed654dd6a0c1c96706f57fe523d30ff53 100644 (file)
@@ -1 +1,2 @@
 DIST rinutils-0.2.0.tar.xz 17008 BLAKE2B d8f40558e50a54a2ab450131c1e3873ff68128d8a6ddfcfd6e8455dff98d3a0b9bbe4baef2a6e8220a3cc9429f1e661b3bf8a6e96a1311352dd0f22d7d331339 SHA512 82d09313f014fd118025438575a90dbc5b9a46d3d58ed9ffc774380d285b32ed00e7d9b453097ce0b8efc20a85a783e178b0d6831e925da3cd65f35037306dc3
+DIST rinutils-0.4.0.tar.xz 17072 BLAKE2B 90cd40fca0f682b730457da04bb392eada83ee2ab2ae3287ffdfd2235776038d6597143ca60c51b9c8d13b366511a5cd084b90811c5cfc7663125952fa009105 SHA512 96c0fc1e8164df8703910a8e14215e1a3fa52d5cc2fdf90af2f21dd064236e2b2b5f44485689553cd0df7cb99aa01f71241983166683934175d907e9f583edb5
diff --git a/dev-libs/rinutils/rinutils-0.4.0.ebuild b/dev-libs/rinutils/rinutils-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..fa04b75
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Set of C headers containing macros and static functions"
+HOMEPAGE="https://www.shlomifish.org/open-source/projects/ https://github.com/shlomif/rinutils"
+SRC_URI="https://github.com/shlomif/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_configure() {
+       local mycmakeargs=(
+               -DDISABLE_APPLYING_RPATH=OFF
+               -DWITH_TEST_SUITE=OFF # tests require perl
+       )
+
+       cmake_src_configure
+}