app-emacs/template: Bump to version 3.3b.
authorUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 15:55:00 +0000 (17:55 +0200)
committerUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 16:58:45 +0000 (18:58 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/template/Manifest
app-emacs/template/template-3.3b.ebuild [new file with mode: 0644]

index 4b0dfa97b7ca856b0696bd45bf84e9bf75671a8e..131bffd624ad885d84213d68e63eb6a025ab7f0d 100644 (file)
@@ -1 +1,2 @@
 DIST template-3.1c.tar.gz 37903 BLAKE2B c6bcd602727d6a6bd60c1b26694b98b28f4f7c752c8c31cd2ad9359297265579b1317effadad956e5aba455b22714985367e84f3295528a1dcc09ff50bf9882d SHA512 d9fee39b67ff986d7c2dccbd09af3ce208f0e1a616a406fefefe4a6399f69a3527fa5609e87d41f7ceec5bf95818a62cb8da62994b28945998f8a9074821914c
+DIST template-3.3b.tar.gz 60370 BLAKE2B 7263faa93dee81f1a5214cebf20bef95dc13a69a8437438849c8377eec784881f952680b4ed52ebf6bbe7dc943a4e77aeb86722772698466aa76506e85ffd146 SHA512 7ca098e1be70ed75b78a7d5e0b216c1cf83d6b2873414cbd09af8aca09f275732ab811204094aed25bd03631590df2b9ddf614fc9df9b4e944ca8c62d6364c1c
diff --git a/app-emacs/template/template-3.3b.ebuild b/app-emacs/template/template-3.3b.ebuild
new file mode 100644 (file)
index 0000000..cd0bf31
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Use templates, decorate comments, auto-update buffers"
+HOMEPAGE="http://emacs-template.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+       elisp-install ${PN} *.{el,elc}
+       elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+       insinto "${SITEETC}/${PN}"
+       doins -r templates
+       doinfo template.info
+}