dev-libs/univalue: Bump to 1.0.5
authorLuke Dashjr <luke-jr+git@utopios.org>
Sun, 9 Feb 2020 17:19:03 +0000 (17:19 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 23 Apr 2020 07:41:07 +0000 (10:41 +0300)
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Closes: https://github.com/gentoo/gentoo/pull/15389
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/univalue/Manifest
dev-libs/univalue/univalue-1.0.5.ebuild [new file with mode: 0644]

index b8fd0e52c73e02557ffc3922736bad01c6976555..e72738a09e7b984d79fee077972e761a169c0450 100644 (file)
@@ -1,3 +1,4 @@
 DIST univalue-1.0.2.tgz 14201 BLAKE2B 47a72a629bc3a0ff193c33d89c3a97e19abca833180473b0a37a6f5a4ba15b7886d1a605a905f7a94af2512e4d1e9f2a7879cae4c5a0af78ac9dfb23a0a581c7 SHA512 727096735dbad082741fb863c9066936a80d7337b1d7c4c289107d240b7f695756a8720f5db320f0c7521b523e299829bd49833b6a31969d8aa43267653a4f2f
 DIST univalue-1.0.3.tar.gz 16820 BLAKE2B 40dd6c4e08e8f4a27731aa0fd6931162f8427a709cc3fc16c049a093d17a08f002a6eb08cf3c4fa9870805f3eed7627c8c9baa7cdc6d6fc8970a085488a955b0 SHA512 1c8358baca82b44d7a762c0cb3b7bef6f36d2f3d0ab29045224c1c39b69fbcbb66573dfb9ee4705f71aadff542cc9f02e98921b1c013748e2c0cd63c386bc1df
 DIST univalue-1.0.4.tar.gz 19677 BLAKE2B 1565a8aabe9b4dfddb2a8b577077bfe50a66aca62e63cfafaaadf1429ad08c0d8aa9f69469b063b2f3c51885addd0a6ab820e06f1ae1b9850de163dd2d1065fd SHA512 cd503ad2f59ea47afbce4acd352ba2baa06b8237f9cfec669353556cff85761e85717ba16c2dc76094b9a9554e5cb27e73e726f2c2d1e6dc5c76e4a5c4cd8edc
+DIST univalue-1.0.5.tgz 20114 BLAKE2B 21f1432bf62325547db7a1ce0c84d80f47b160dc19de3567eea4678a0f242fb2c814daa6955f7a2b45c5b75e859b6d2ecdfcd68abe58f573752c0f037a099d10 SHA512 9c2273d82267aaecd2b017d00ae8bc40f7f40fff10ce6176bbea0df93d7c9478fc76a38101f0b55ded0a3c4fc49f00c868aad33deca4d936b85342ec6a394eab
diff --git a/dev-libs/univalue/univalue-1.0.5.ebuild b/dev-libs/univalue/univalue-1.0.5.ebuild
new file mode 100644 (file)
index 0000000..5c07a1e
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ universal value object and JSON library"
+HOMEPAGE="https://github.com/jgarzik/univalue"
+SRC_URI="https://codeload.github.com/jgarzik/${PN}/tar.gz/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --disable-static
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}