dev-ros/ament_cmake_export_libraries: Declare python_check_deps().
authorAlexis Ballier <aballier@gentoo.org>
Mon, 16 Dec 2019 11:30:51 +0000 (12:30 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 16 Dec 2019 13:49:43 +0000 (14:49 +0100)
Thanks to mgorny.
Closes: https://bugs.gentoo.org/702728
Package-Manager: Portage-2.3.81, Repoman-2.3.20

Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_export_libraries/ament_cmake_export_libraries-0.8.1.ebuild
dev-ros/ament_cmake_export_libraries/ament_cmake_export_libraries-9999.ebuild

index c3827165a1ecb4dc565e9d70b49ea9e5744fa25f..3a206672bb44ea22e01eaa13fb7a1926c067f91e 100644 (file)
@@ -39,3 +39,8 @@ BDEPEND="
        $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
+
+python_check_deps() {
+       has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+               has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
index c3827165a1ecb4dc565e9d70b49ea9e5744fa25f..3a206672bb44ea22e01eaa13fb7a1926c067f91e 100644 (file)
@@ -39,3 +39,8 @@ BDEPEND="
        $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
+
+python_check_deps() {
+       has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+               has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}