app-office/ledger: Fix build with >=dev-libs/boost-1.61
authorFrancesco Turco <fturco@fastmail.fm>
Thu, 7 Sep 2017 20:26:04 +0000 (22:26 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Oct 2017 16:51:36 +0000 (18:51 +0200)
Gentoo-bug: 609108
Closes: https://github.com/gentoo/gentoo/pull/5655

app-office/ledger/files/ledger-3.1.1-boost.patch [new file with mode: 0644]
app-office/ledger/ledger-3.1.1.ebuild

diff --git a/app-office/ledger/files/ledger-3.1.1-boost.patch b/app-office/ledger/files/ledger-3.1.1-boost.patch
new file mode 100644 (file)
index 0000000..b69a42a
--- /dev/null
@@ -0,0 +1,22 @@
+From 1856b8c4902498843f4da37a7aaeb2ce85acc1d3 Mon Sep 17 00:00:00 2001
+From: Denis <dkasak@users.noreply.github.com>
+Date: Mon, 12 Sep 2016 12:49:40 +0200
+Subject: [PATCH] Fix compilation error with boost 1.61
+
+---
+ src/item.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/item.h b/src/item.h
+index ca16d87b3..4dc6df7e6 100644
+--- a/src/item.h
++++ b/src/item.h
+@@ -92,7 +92,7 @@ class item_t : public supports_flags<uint_least16_t>, public scope_t
+   typedef std::pair<optional<value_t>, bool> tag_data_t;
+   typedef std::map<string, tag_data_t,
+-                   function<bool(string, string)> > string_map;
++                   std::function<bool(string, string)> > string_map;
+   state_t              _state;
+   optional<date_t>     _date;
index f32cda9c830fcdd02401b90355d023df06589e7a..31ed49d068b16d1d283f4144066b13274a704381 100644 (file)
@@ -42,6 +42,8 @@ DEPEND="
        )
 "
 
+PATCHES=( "${FILESDIR}/${P}-boost.patch" ) # bug 609108
+
 # Building with python integration seems to fail without 8G available
 # RAM(!)  Since the memory check in check-reqs doesn't count swap, it
 # may be unfair to fail the build entirely on the memory test alone.