dev-util/meson: remove patching from live ebuild
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 15 Feb 2020 19:55:02 +0000 (13:55 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 15 Feb 2020 19:55:30 +0000 (13:55 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-util/meson/meson-9999.ebuild

index 7b35af5187364a7728ccabcf84ce7d6d9c7713d9..ab875e3bb07b9e8fb673d6d47d26531e5dca5bdb 100644 (file)
@@ -34,21 +34,6 @@ DEPEND="
        )
 "
 
-python_prepare_all() {
-       # ASAN and sandbox both want control over LD_PRELOAD
-       # https://bugs.gentoo.org/673016
-       sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
-
-       # ASAN is unsupported on some targets
-       # https://bugs.gentoo.org/692822
-       sed -i -e 's/test_pch_with_address_sanitizer/_&/' run_unittests.py || die
-
-       # Broken due to python2 script created by python_wrapper_setup
-       rm -r "test cases/frameworks/1 boost" || die
-
-       distutils-r1_python_prepare_all
-}
-
 src_test() {
        tc-export PKG_CONFIG
        if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then