media-fonts/fontawesome: version bump to 5.13.0 + new proxy-maint
authorAisha Tammy <gentoo@aisha.cc>
Thu, 23 Apr 2020 12:20:27 +0000 (08:20 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 07:44:05 +0000 (10:44 +0300)
Closes: https://bugs.gentoo.org/719036

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Closes: https://github.com/gentoo/gentoo/pull/15483
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-fonts/fontawesome/Manifest
media-fonts/fontawesome/fontawesome-5.13.0.ebuild [new file with mode: 0644]
media-fonts/fontawesome/fontawesome-9999.ebuild [new file with mode: 0644]
media-fonts/fontawesome/metadata.xml

index 63c7c6b827499390b37db3a6ca87e9dba65a88a5..f14861da42ce434e10f3d23d28663e4f1a14921f 100644 (file)
@@ -1,3 +1,4 @@
 DIST fontawesome-4.7.0.tar.gz 2672776 BLAKE2B c20474c0167665d82fcbe74984ad9c44fa1155a2a5363222981d6c32f40a3bf13bfc2c582d78e8d36e57939f8af3810fa823f2241d1924a83a05c79ed08cface SHA512 913e5eec2211111e9601c92059745344766f4c3a6f3563cbc6f8a5f3850a0101bab8f3f992a97c6f1c264a2bbb5163f3feecc6b3f64fcb22c9592d2d38cc777d
 DIST fontawesome-5.1.0.tar.gz 10505651 BLAKE2B 0ec84cdf36855ba43e5858b2e8b12a93c9ec950216b64fa307e1fa058e05f83f08c820e4a3b95432e30c33ee4efe5931bee7077ff182d52725068c53bf387b6f SHA512 1f35f0d326e1f896b606d851577fe99639c164101f236c47966289a8a7e3b1e64fea3f1338d12f327777db56ec35b1fcb5d6de250276bcb468fec114d4c3928f
 DIST fontawesome-5.11.2.tar.gz 10542743 BLAKE2B d17afa447acfa56ad42b6f36c6fd7ec049434028c00259f53f36d0896e2a679f83880c8e71f277316728d1ba5f18cf4af7cb22a935b0a300acc423bc02790fa8 SHA512 14267debf243aa3210125b4e45a2ab41cbcab599f2abab42e64432ff7b1f6b5716724012bc973b77bcee1b2d488738720ffa9b4f6ebaf8f4cc3375ff066fb72a
+DIST fontawesome-5.13.0.tar.gz 10998459 BLAKE2B 69ddfb0d8b3bb1a15911445b934cf0321e645164b34fc9f7844f0df04840a3e8d4d425b14589341cec0613ea4f2109678250198a1d5002e69c394eb053ceb4a2 SHA512 9fd3e1115acef6ac84667cf546374b204b947e229e4c645ab33f51026e993689a8295e7c0b02c88d735c4399efcd454f4252dcde7008eefb85c13846bf7c5bc4
diff --git a/media-fonts/fontawesome/fontawesome-5.13.0.ebuild b/media-fonts/fontawesome/fontawesome-5.13.0.ebuild
new file mode 100644 (file)
index 0000000..73c98da
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Font-Awesome"
+inherit font
+
+DESCRIPTION="The iconic font"
+HOMEPAGE="https://fontawesome.com"
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/FortAwesome/${MY_PN}.git"
+else
+       SRC_URI="https://github.com/FortAwesome/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="CC-BY-4.0 OFL-1.1"
+SLOT="0/5"
+IUSE="+otf ttf"
+
+REQUIRED_USE="|| ( otf ttf )"
+
+src_install() {
+       if use otf; then
+               FONT_S="${S}/otfs" FONT_SUFFIX="otf" font_src_install
+       fi
+       if use ttf; then
+               FONT_S="${S}/webfonts" FONT_SUFFIX="ttf" font_src_install
+       fi
+}
diff --git a/media-fonts/fontawesome/fontawesome-9999.ebuild b/media-fonts/fontawesome/fontawesome-9999.ebuild
new file mode 100644 (file)
index 0000000..73c98da
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Font-Awesome"
+inherit font
+
+DESCRIPTION="The iconic font"
+HOMEPAGE="https://fontawesome.com"
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/FortAwesome/${MY_PN}.git"
+else
+       SRC_URI="https://github.com/FortAwesome/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="CC-BY-4.0 OFL-1.1"
+SLOT="0/5"
+IUSE="+otf ttf"
+
+REQUIRED_USE="|| ( otf ttf )"
+
+src_install() {
+       if use otf; then
+               FONT_S="${S}/otfs" FONT_SUFFIX="otf" font_src_install
+       fi
+       if use ttf; then
+               FONT_S="${S}/webfonts" FONT_SUFFIX="ttf" font_src_install
+       fi
+}
index cbc37d4c0550fe6943bf148e9fd81e1e17e76434..795d5dc16535fe3a81a4929a1d60d9866998ce74 100644 (file)
@@ -1,10 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
-       <upstream>
-               <remote-id type="github">FortAwesome/Font-Awesome</remote-id>
-       </upstream>
+       <maintainer type="person">
+               <email>gentoo@aisha.cc</email>
+               <name>Aisha Tammy</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <use>
                <flag name="otf">Install the OpenType version of the font</flag>
                <flag name="ttf">Install the TrueType version of the font</flag>