media-libs/ptex: Drop 2.1.28-r1 and 2.3.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 9 Jun 2019 20:22:18 +0000 (22:22 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 9 Jun 2019 20:24:16 +0000 (22:24 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/ptex/Manifest
media-libs/ptex/files/ptex-2.1.28-20170213.patch [deleted file]
media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch [deleted file]
media-libs/ptex/files/ptex-2.3.0-cxx11.patch [deleted file]
media-libs/ptex/ptex-2.1.28-r1.ebuild [deleted file]
media-libs/ptex/ptex-2.3.0.ebuild [deleted file]

index 439468d5e6e7298a6b7e5a09060f18512c06f2b3..185404267ba5899bd1e2a998a83811a573b5e106 100644 (file)
@@ -1,3 +1 @@
-DIST ptex-2.1.28.tar.gz 305327 BLAKE2B 4a91b08ae326e8ed8d420022c693ea60cb21908380b8c49a7672771686f9dd2ef05151b7d43755bc63ab6624db772c2b53d1ffdcdea9c1dff7627cc3fe0f3b15 SHA512 ddce3c79f14d196e550c1e8a5b371482f88190cd667a2e2aa84601de1639f7cabb8571c1b3a49b48df46ce550d27088a00a67b1403c3bfec2ed73437c3dca3e8
-DIST ptex-2.3.0.tar.gz 306462 BLAKE2B 790e3623ce6ebae2dfd8884d8e19e62395c54432289d88bdcf3a01c8ae1ef752ca88869357ac1e4657d59f1ca73d311a3fb9a08efe4e145ca259eff93d8a3b6a SHA512 2d9d320e4205236a4eff05ec3c67d085624809ebefa89fa3b943d18a8b2b6a5f61c022a4cc4363a7c6ceccfb9eac4f8738dff2e90a3355814f2c4ff096c09992
 DIST ptex-2.3.2.tar.gz 308550 BLAKE2B 7b3145dbf9d2c13140c3f20ed606ee911deed3c38fd30adfbb01b58c3af5794dbd4e0fa1fbab6e8ae83556a0ffec725bf077271abf752f1271ed721ca200a1ff SHA512 dbc557dc5e1761204ee3483af9bf4ff1504cbd7955e0405dc27a51f7182e2445e41db086b2792c2491aa2cbaddc74e523170a4b3d25e44d332123d5b7081f4b9
diff --git a/media-libs/ptex/files/ptex-2.1.28-20170213.patch b/media-libs/ptex/files/ptex-2.1.28-20170213.patch
deleted file mode 100644 (file)
index 335d077..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt   2016-04-04 18:14:05.000000000 +0100
-+++ b/CMakeLists.txt   2017-02-13 22:59:10.000000000 +0000
-@@ -16,7 +16,7 @@ else ()
- endif ()
- if (NOT WIN32)
--    set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic")
-+    set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
- endif ()
- if(MSVC)
-diff -purN a/Makefile b/Makefile
---- a/Makefile 2016-04-04 18:14:05.000000000 +0100
-+++ b/Makefile 2017-02-13 22:59:10.000000000 +0000
-@@ -17,6 +17,10 @@ ifdef PRMAN_15_COMPATIBLE_PTEX
-     CMAKE_FLAGS += -DPRMAN_15_COMPATIBLE_PTEX:BOOL=TRUE
- endif
-+ifdef TOOLCHAIN
-+    CMAKE_FLAGS += -DCMAKE_TOOLCHAIN_FILE=$(TOOLCHAIN)
-+endif
-+
- # make V=1 shortcut for VERBOSE=1
- ifdef V
-     VERBOSE=1
-diff -purN a/src/ptex/PtexHashMap.h b/src/ptex/PtexHashMap.h
---- a/src/ptex/PtexHashMap.h   2016-04-04 18:14:05.000000000 +0100
-+++ b/src/ptex/PtexHashMap.h   2017-02-13 22:59:10.000000000 +0000
-@@ -284,14 +284,11 @@ private:
-     Entry* lockEntriesAndGrowIfNeeded(size_t& newMemUsed)
-     {
--        while (_size*2 >= _numEntries) {
--            Entry* entries = lockEntries();
--            if (_size*2 >= _numEntries) {
--                entries = grow(entries, newMemUsed);
--            }
--            return entries;
-+        Entry* entries = lockEntries();
-+        if (_size*2 >= _numEntries) {
-+            entries = grow(entries, newMemUsed);
-         }
--        return lockEntries();
-+        return entries;
-     }
-     Entry* grow(Entry* oldEntries, size_t& newMemUsed)
-diff -purN a/src/ptex/PtexIO.h b/src/ptex/PtexIO.h
---- a/src/ptex/PtexIO.h        2016-04-04 18:14:05.000000000 +0100
-+++ b/src/ptex/PtexIO.h        2017-02-13 22:59:10.000000000 +0000
-@@ -40,6 +40,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- PTEX_NAMESPACE_BEGIN
-+#pragma pack(push, 1)
- struct Header {
-     uint32_t magic;
-     uint32_t version;
-@@ -98,6 +99,7 @@ struct EditMetaDataHeader {
-     uint32_t metadatazipsize;
-     uint32_t metadatamemsize;
- };
-+#pragma pack(pop)
- const uint32_t Magic = 'P' | ('t'<<8) | ('e'<<16) | ('x'<<24);
- const int HeaderSize = sizeof(Header);
-diff -purN a/.workonrc.products b/.workonrc.products
---- a/.workonrc.products       1970-01-01 01:00:00.000000000 +0100
-+++ b/.workonrc.products       2017-02-13 22:59:10.000000000 +0000
-@@ -0,0 +1 @@
-+Ptex
diff --git a/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch b/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
deleted file mode 100644 (file)
index fd79759..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt   2017-02-13 22:59:10.000000000 +0000
-+++ b/CMakeLists.txt   2017-08-08 14:19:10.325817085 +0100
-@@ -8,11 +8,16 @@ include(FindThreads)
- enable_testing()
--# Detect the build type from the $FLAVOR environment variable
--if ("$ENV{FLAVOR}" MATCHES "debug")
--    set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
--else ()
--    set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
-+if (NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
-+    # Detect the build type from the $FLAVOR environment variable
-+    # Default to optimized Release builds when unspecified.
-+    if ("$ENV{FLAVOR}" MATCHES "debug")
-+        set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
-+    elseif ("$ENV{FLAVOR}" MATCHES "profile")
-+        set(CMAKE_BUILD_TYPE "RelWithDebInfo" CACHE STRING "type of build" FORCE)
-+    else ()
-+        set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
-+    endif ()
- endif ()
- if (NOT WIN32)
-diff -purN a/Makefile b/Makefile
---- a/Makefile 2017-02-13 22:59:10.000000000 +0000
-+++ b/Makefile 2017-08-08 14:19:16.939829578 +0100
-@@ -21,6 +21,10 @@ ifdef TOOLCHAIN
-     CMAKE_FLAGS += -DCMAKE_TOOLCHAIN_FILE=$(TOOLCHAIN)
- endif
-+ifdef BUILD_TYPE
-+    CMAKE_FLAGS += -DCMAKE_BUILD_TYPE=$(BUILD_TYPE)
-+endif
-+
- # make V=1 shortcut for VERBOSE=1
- ifdef V
-     VERBOSE=1
diff --git a/media-libs/ptex/files/ptex-2.3.0-cxx11.patch b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
deleted file mode 100644 (file)
index f0b6000..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt   2016-04-04 18:14:05.000000000 +0100
-+++ b/CMakeLists.txt   2017-02-13 22:59:10.000000000 +0000
-@@ -16,7 +16,7 @@ else ()
- endif ()
- if (NOT WIN32)
--    set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
-+    set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
- endif ()
- if(MSVC)
diff --git a/media-libs/ptex/ptex-2.1.28-r1.ebuild b/media-libs/ptex/ptex-2.1.28-r1.ebuild
deleted file mode 100644 (file)
index 6b688c9..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
-HOMEPAGE="http://ptex.us/"
-SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="sys-libs/zlib:="
-DEPEND="${RDEPEND}
-       app-doc/doxygen"
-
-PATCHES=(
-       "${FILESDIR}/${P}-20170213.patch"
-       "${FILESDIR}/${P}-allow-custom-build-type.patch"
-)
-
-mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html" )
diff --git a/media-libs/ptex/ptex-2.3.0.ebuild b/media-libs/ptex/ptex-2.3.0.ebuild
deleted file mode 100644 (file)
index ce1f9fd..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
-HOMEPAGE="http://ptex.us/"
-SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="static-libs"
-
-RDEPEND="sys-libs/zlib:="
-DEPEND="${RDEPEND}
-       app-doc/doxygen"
-
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}/${P}-cxx11.patch"
-)
-
-src_configure() {
-       local mycmakeargs=(
-               -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
-               -DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
-       )
-       cmake-utils_src_configure
-}