Version bump, new upstream version. Cleaning up the ebuild a bit.
authorChristian Heim <phreak@gentoo.org>
Sun, 28 Jan 2007 21:28:13 +0000 (21:28 +0000)
committerChristian Heim <phreak@gentoo.org>
Sun, 28 Jan 2007 21:28:13 +0000 (21:28 +0000)
Package-Manager: portage-2.1.2-r4

dev-libs/apr-util/ChangeLog
dev-libs/apr-util/apr-util-0.9.13.ebuild [new file with mode: 0644]
dev-libs/apr-util/files/digest-apr-util-0.9.13 [new file with mode: 0644]
dev-libs/apr/ChangeLog
dev-libs/apr/apr-0.9.13.ebuild [new file with mode: 0644]
dev-libs/apr/files/digest-apr-0.9.13 [new file with mode: 0644]

index 7d143a87dcb18cd1e4cb48f2c75c0f2be2c881ec..5e929e8ec193e4464c67df28bbab36f4e9a04f8f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/apr-util
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.68 2007/01/28 20:06:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.69 2007/01/28 21:28:13 phreak Exp $
+
+*apr-util-0.9.13 (28 Jan 2007)
+
+  28 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-util-0.9.13.ebuild:
+  Version bump, new upstream version. Cleaning up the ebuild a bit.
 
   28 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
   -files/apr-util-0.9.x-161086-161087.patch, metadata.xml,
diff --git a/dev-libs/apr-util/apr-util-0.9.13.ebuild b/dev-libs/apr-util/apr-util-0.9.13.ebuild
new file mode 100644 (file)
index 0000000..d6225b5
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.13.ebuild,v 1.1 2007/01/28 21:28:13 phreak Exp $
+
+inherit eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+       ~dev-libs/apr-${PV}
+       berkdb? ( =sys-libs/db-4* )
+       gdbm? ( sys-libs/gdbm )
+       ldap? ( =net-nds/openldap-2* )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}"/apr-util-0.9.12-linking.patch
+       elibtoolize || die "elibtoolize failed"
+}
+
+
+src_compile() {
+       local myconf=""
+
+       use ldap && myconf="${myconf} --with-ldap"
+       myconf="${myconf} $(use_with gdbm)"
+
+       if use berkdb; then
+               dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+               dbver="$(db_ver_to_slot "$dbver")"
+               dbver="${dbver/\./}"
+               myconf="${myconf} --with-dbm=db${dbver}
+               --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+       else
+               myconf="${myconf} --without-berkeley-db"
+       fi
+
+       econf \
+               --datadir=/usr/share/apr-util-0 \
+               --with-apr=/usr \
+               --with-expat=/usr \
+               $myconf || die "econf failed!"
+
+       emake || die "emake failed!"
+}
+
+src_install() {
+       make DESTDIR="${D}" installbuilddir=/usr/share/apr-util-0/build install || die "make install failed!"
+
+       #bogus values pointing at /var/tmp/portage
+       sed -i -e 's:APU_SOURCE_DIR=.*:APU_SOURCE_DIR=:g' "${D}"/usr/bin/apu-config
+       sed -i -e 's:APU_BUILD_DIR=.*:APU_BUILD_DIR=/usr/share/apr-util-0/build:g' "${D}"/usr/bin/apu-config
+
+       dodoc CHANGES NOTICE
+
+       # Will install as portage user when using userpriv. Fixing
+       chown -R root:0 "${D}"/usr/include/apr-0/
+
+       # This file is only used on AIX systems, which gentoo is not,
+       # and causes collisions between the SLOTs, so kill it
+       rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}
diff --git a/dev-libs/apr-util/files/digest-apr-util-0.9.13 b/dev-libs/apr-util/files/digest-apr-util-0.9.13
new file mode 100644 (file)
index 0000000..fe458f3
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 31e3881af0d9546286b0057717cdb89b apr-util-0.9.13.tar.gz 593575
+RMD160 34d6e517de6cb64e0b1aef45a99ee64f9ceba130 apr-util-0.9.13.tar.gz 593575
+SHA256 8c5a2c9e0434a391360bbf3573a403a3f4f326d1b562f64276cbd4f92066da7f apr-util-0.9.13.tar.gz 593575
index 011a1cae4e793c028d08363d035834a4a772bacb..e310f4b1249c83a8fa012911e3e573cbe13ed767 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/apr
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.76 2007/01/28 20:11:11 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.77 2007/01/28 21:24:41 phreak Exp $
+
+*apr-0.9.13 (28 Jan 2007)
+
+  28 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-0.9.13.ebuild:
+  Version bump, new upstream version. Cleaning up the ebuild a bit.
 
   28 Jan 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
   -apr-0.9.6-r3.ebuild, -apr-0.9.6-r4.ebuild, -apr-0.9.7.ebuild,
diff --git a/dev-libs/apr/apr-0.9.13.ebuild b/dev-libs/apr/apr-0.9.13.ebuild
new file mode 100644 (file)
index 0000000..43ce2eb
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.13.ebuild,v 1.1 2007/01/28 21:24:41 phreak Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="ipv6 urandom"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}"/apr-0.9.12-linking.patch
+       elibtoolize || die "elibtoolize failed"
+
+}
+
+src_compile() {
+       myconf="--datadir=/usr/share/apr-0"
+
+       myconf="${myconf} $(use_enable ipv6)"
+       myconf="${myconf} --enable-threads"
+       myconf="${myconf} --enable-nonportable-atomics"
+       if use urandom; then
+               einfo "Using /dev/urandom as random device"
+               myconf="${myconf} --with-devrandom=/dev/urandom"
+       else
+               einfo "Using /dev/random as random device"
+               myconf="${myconf} --with-devrandom=/dev/random"
+       fi
+
+       # We pre-load the cache with the correct answer!  This avoids
+       # it violating the sandbox.  This may have to be changed for
+       # non-Linux systems or if sem_open changes on Linux.  This
+       # hack is built around documentation in /usr/include/semaphore.h
+       # and the glibc (pthread) source
+       # See bugs 24215 and 133573
+       echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+       econf ${myconf} || die "econf failed!"
+       emake || die "emake failed!"
+}
+
+src_install() {
+       make DESTDIR="${D}" installbuilddir=/usr/share/apr-0/build install || die "make install failed!"
+
+       # bogus values pointing at /var/tmp/portage
+       sed -i -e 's:APR_SOURCE_DIR=.*:APR_SOURCE_DIR=/usr/share/apr-0:g' "${D}"/usr/bin/apr-config
+       sed -i -e 's:APR_BUILD_DIR=.*:APR_BUILD_DIR=/usr/share/apr-0/build:g' "${D}"/usr/bin/apr-config
+
+       sed -i -e 's:apr_builddir=.*:apr_builddir=/usr/share/apr-0/build:g' "${D}"/usr/share/apr-0/build/apr_rules.mk
+       sed -i -e 's:apr_builders=.*:apr_builders=/usr/share/apr-0/build:g' "${D}"/usr/share/apr-0/build/apr_rules.mk
+
+       cp -p build/*.awk "${D}"/usr/share/apr-0/build
+       cp -p build/*.sh "${D}"/usr/share/apr-0/build
+       cp -p build/*.pl "${D}"/usr/share/apr-0/build
+
+       dodoc CHANGES LICENSE NOTICE
+
+       # This file is only used on AIX systems, which gentoo is not,
+       # and causes collisions between the SLOTs, so kill it
+       rm "${D}"/usr/$(get_libdir)/apr.exp
+}
diff --git a/dev-libs/apr/files/digest-apr-0.9.13 b/dev-libs/apr/files/digest-apr-0.9.13
new file mode 100644 (file)
index 0000000..95ddccf
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 233894af598d8347fd68cf836e7dee91 apr-0.9.13.tar.gz 1051795
+RMD160 0183645d0065eb8b3eca0602820318ab3c89a179 apr-0.9.13.tar.gz 1051795
+SHA256 64bb493b634c442db4f18deac37a07deb8d37c994a2507f8eba756f926a26204 apr-0.9.13.tar.gz 1051795