sys-boot/nettrom: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 10:15:15 +0000 (12:15 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 10:15:15 +0000 (12:15 +0200)
Closes: https://bugs.gentoo.org/697186
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
sys-boot/nettrom/nettrom-2.3.3.ebuild

index 15a432011ba8ceac204c26e72365fb21c788d448..a0311ddca387e2042d527d74b81b02bc69acccb5 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="NetWinder ARM bootloader and utilities"
 HOMEPAGE="http://www.netwinder.org/"
@@ -10,14 +10,20 @@ SRC_URI="http://wh0rd.org/gentoo/${P}.tar.gz"
 LICENSE="all-rights-reserved"
 SLOT="0"
 KEYWORDS="-* arm"
-IUSE=""
 RESTRICT="mirror bindist"
 
 S=${WORKDIR}
 
+QA_PREBUILT="
+       /sbin/flashwrite
+       /usr/sbin/logowrite
+       /usr/sbin/logoread"
+QA_PRESTRIPPED="${QA_PREBUILT}"
+
 src_install() {
-       cp -r "${S}"/* "${D}"/ || die "install failed"
-       cd "${D}"/usr
-       mkdir share
-       mv man share
+       doman usr/man/man8/flashwrite.8
+       rm -r usr/man || die
+
+       insinto /
+       doins -r .
 }