app-portage/unsymlink-lib: Bump to v17
authorMichał Górny <mgorny@gentoo.org>
Thu, 20 Jun 2019 07:00:11 +0000 (09:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 20 Jun 2019 07:00:11 +0000 (09:00 +0200)
Closes: https://bugs.gentoo.org/688216
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/unsymlink-lib/Manifest
app-portage/unsymlink-lib/unsymlink-lib-17.ebuild [new file with mode: 0644]

index 2c29f908b6de590c0c56e427efa59f66dc366295..4e9e61daa9e5fd1880debe66513f47dd78400487 100644 (file)
@@ -1,2 +1,3 @@
 DIST unsymlink-lib-15.tar.gz 10145 BLAKE2B 500b78a84cd555319952ce6420af012354952ebd83983db121f1a48ee34d5c2ce9a9f56ce635d6f77eb38058b79d42cf94d2e421414095c188949db523aacbe0 SHA512 37b8cc4eb7b787a1ccc97750df9fcd4516c2c4ac110c5191b4be3999b1eb994ee567e0f4387aaafe243a745efa61c0d48d78b7f9a4a58bb7f896ccd7bdce03a7
 DIST unsymlink-lib-16.tar.gz 10139 BLAKE2B 8e43fe85747d97fa44ae30cf6f276e8e5557141004c0c6ec5f1b998c0f5c121e9fb6bb3f7d711d11ca962c703caa7dc6014ddfde2c6ccf16807264a132e37940 SHA512 0c5ebab3622aad1f8a02c2530bfb3f6d48c0ac9744fdde94e8a9b151c5773d10ae642c122642d5f7e2bd442d5969863d8f5f0586c8ed484fa22ac42143a06417
+DIST unsymlink-lib-17.tar.gz 10550 BLAKE2B 036cf63e3619113763f01086fbd952fb2a6efda4d4f4989a5d8cadc0d47b439cba0fab84d53336d615ccbec4e0815519cd4709162f11bbf5fa42c770b928f6f2 SHA512 b981419e320da74f983c184f2b9739b0f1cdae7adf1b9d29c3221b7d010432f6844ff3bdf93793b2f701e2337acebc28a6bd2df0763a081cd8e53a8400aaea42
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-17.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-17.ebuild
new file mode 100644 (file)
index 0000000..90b56e6
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_test() {
+       # tests are docker-based
+       :
+}
+
+src_install() {
+       python_doscript unsymlink-lib
+       dodoc README
+}