net-vpn/i2pd: version bump 2.31.0
authorAlexey Korepanov <kaikaikai@yandex.ru>
Sat, 11 Apr 2020 14:33:21 +0000 (15:33 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 16 Apr 2020 08:09:48 +0000 (11:09 +0300)
Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-vpn/i2pd/Manifest
net-vpn/i2pd/i2pd-2.31.0.ebuild [new file with mode: 0644]

index 40211abe7931332f5774259846d83d097df55d8b..566a3590ac8720ef25b6154f6941b6c31f902ae0 100644 (file)
@@ -2,3 +2,4 @@ DIST i2pd-2.27.0.tar.gz 1073766 BLAKE2B 331407c6bed3ed49e2438590a814ce91301bfe31
 DIST i2pd-2.28.0.tar.gz 1079208 BLAKE2B 2cc84ff156c05395ce13fd0cbabb667d44d88df252c02775dee3af0ea2715487ea35614175a4dcd6f4af8a2f8fc071857beb67e85620d32e952341db04b3be7d SHA512 9bcae8dfb5a2c77b03e4c4d4816b1666f2a0d95e0c806f952a095182dfc62bdc142f5cde6a9643f7a3c6d385f906c00011b4d291fe53ab177d36d63b6a698599
 DIST i2pd-2.29.0.tar.gz 1079654 BLAKE2B 762f06908342c7e6508f47f7bd7479454f0a4594647aa9e0a9be5e7f6ae28140a1073e10138f3e210b7add943a31617260b475d9ee5915c367dc4f80b3036bb1 SHA512 dfa1c212c217eb2eae40f3f8151d35164c52df630e658dcb261cc9532623377dee376d1c493e8b8bdcae3245ae389e06adf5ef551951d4e139f1626b8432c15b
 DIST i2pd-2.30.0.tar.gz 1087411 BLAKE2B adfd6d2eebb2bbd0fe931a9a96110d0bf540ceff18231afc88ba4df7b428ec702297871ecafb812cd130e68eb8f6127e3f7a4645631df7ca2a723d0a45d8723c SHA512 d27c5e5b7ae7c78be14ad96ac458c0f3a45e31ee5fbdf59d5c6278d0195909badc5917a258b5de37d6a255c20a8c3cb0c0ddc3291a110444a96f475b662a119b
+DIST i2pd-2.31.0.tar.gz 1092238 BLAKE2B 61424b8d5796511a1bae4d0274b86fa198e0fb2e590312e7e5039533bca2ded494f9bdd7406951c82a99259772581ee716159f6500921f9fb8b5fd4aa217ce9a SHA512 af1583c6c2fb2073d6d3d32f0b394da3f1bc4a3d232aa47880f457447c6592801c48f6a05b1a7d2955c58d888c4c574e15082bf2583921797e24e5cda4c188e0
diff --git a/net-vpn/i2pd/i2pd-2.31.0.ebuild b/net-vpn/i2pd/i2pd-2.31.0.ebuild
new file mode 100644 (file)
index 0000000..68023f3
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd cmake toolchain-funcs
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="cpu_flags_x86_aes cpu_flags_x86_avx i2p-hardening libressl static +upnp"
+
+RDEPEND="
+       acct-user/i2pd
+       acct-group/i2pd
+       !static? (
+               dev-libs/boost:=[threads]
+               !libressl? ( dev-libs/openssl:0=[-bindist] )
+               libressl? ( dev-libs/libressl:0= )
+               upnp? ( net-libs/miniupnpc )
+       )"
+DEPEND="${RDEPEND}
+       static? (
+               dev-libs/boost:=[static-libs,threads]
+               !libressl? ( dev-libs/openssl:0=[static-libs] )
+               libressl? ( dev-libs/libressl:0=[static-libs] )
+               sys-libs/zlib:=[static-libs]
+               upnp? ( net-libs/miniupnpc[static-libs] )
+       )"
+
+CMAKE_USE_DIR="${S}/build"
+
+DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
+
+PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch"
+       "${FILESDIR}/i2pd-2.25.0-lib-path.patch" )
+
+pkg_pretend() {
+       if use i2p-hardening && ! tc-is-gcc; then
+               die "i2p-hardening requires gcc"
+       fi
+}
+
+src_configure() {
+       mycmakeargs=(
+               -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
+               -DWITH_AVX=$(usex cpu_flags_x86_avx ON OFF)
+               -DWITH_HARDENING=$(usex i2p-hardening ON OFF)
+               -DWITH_PCH=OFF
+               -DWITH_STATIC=$(usex static ON OFF)
+               -DWITH_UPNP=$(usex upnp ON OFF)
+               -DWITH_LIBRARY=ON
+               -DWITH_BINARY=ON
+       )
+       cmake_src_configure
+}
+
+src_install() {
+       cmake_src_install
+
+       # config
+       insinto /etc/i2pd
+       doins contrib/i2pd.conf
+       doins contrib/tunnels.conf
+
+       # working directory
+       insinto /var/lib/i2pd
+       doins -r contrib/certificates
+
+       # add /var/lib/i2pd/certificates to CONFIG_PROTECT
+       doenvd "${FILESDIR}/99i2pd"
+
+       # openrc and systemd daemon routines
+       newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
+       newinitd "${FILESDIR}/i2pd-2.6.0-r3.initd" i2pd
+       systemd_newunit "${FILESDIR}/i2pd-2.6.0-r3.service" i2pd.service
+
+       # logrotate
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/i2pd-2.6.0-r3.logrotate" i2pd
+}
+
+pkg_postinst() {
+       if [[ -f ${EROOT}/etc/i2pd/subscriptions.txt ]]; then
+               ewarn
+               ewarn "Configuration of the subscriptions has been moved from"
+               ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
+               ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
+       fi
+}