mail-client/alpine: bring back chappa patches
authorRobert Siebeck <gentoo.2019@r123.de>
Fri, 24 Apr 2020 20:51:52 +0000 (22:51 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:28 +0000 (11:46 +0300)
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
mail-client/alpine/Manifest
mail-client/alpine/alpine-2.22-r1.ebuild [new file with mode: 0644]
mail-client/alpine/metadata.xml

index e972ef4961207ccf57c2e78c6a3b30b695aace01..3330c0fc2c09f166542f11793b3a2acca28d7627 100644 (file)
@@ -1,2 +1,3 @@
+DIST alpine-2.22-chappa.patch.gz 173232 BLAKE2B ac2cfc22119c9e60fdc053212447fb5df8cc59781c049329560d21e19e67d700fe45a07649352747583b500a605499eeb61dfd83ba150c3bd58f4033486e2581 SHA512 9db36ebb4fb2efaee975ed33d44cf95780c56075cbc0ad39056268248db38109e1bb04e279b40cdd085b3dfec89d0f9c69aa4ddf5a64b5708437909661288e23
 DIST alpine-2.22.tar.xz 6336604 BLAKE2B 65cab2000b6c606c002efcca6e731d2c87329b4685dec81d202e95598b4302175137ea84f079af1f766a6ef99d0b2cb51132e12539bea7f4d24954bb48af7bea SHA512 7737dce02ac94170948df7fccb61380c6cb101190e37f5b3ba281d573f54df1db24569d177b460f49bfff381a922be2e4b0f3a0f1a213d88a64d361aedc3c4f1
 DIST alpine-843b2f1.tar.gz 7490140 BLAKE2B 13ac5ef43dd729a7cf21b44dcd6feace3e1813672aec537fd05d5ff90b67bec145ceef71cfcf35b0cb7e250bb307556f5dcf8ebb024bc6366fd0ace0a7c41161 SHA512 106caa7bfe86fd5e82554ba68b9ee579cd8495bcd0dfbf82d9d75da2df3bd292d42d67af8ec737091f2a820b2555c25bbf0058c9c7bb5de5f950b570ffc25c4d
diff --git a/mail-client/alpine/alpine-2.22-r1.ebuild b/mail-client/alpine/alpine-2.22-r1.ebuild
new file mode 100644 (file)
index 0000000..3bd3ad9
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa.patch"
+SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz
+       chappa? ( http://alpine.x10host.com/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads +chappa"
+
+DEPEND=">=sys-libs/ncurses-5.1:0=
+       kerberos? ( app-crypt/mit-krb5 )
+       ldap? ( net-nds/openldap )
+       spell? ( app-text/aspell )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+"
+RDEPEND="${DEPEND}
+       app-misc/mime-types
+"
+
+PATCHES=(
+       "${FILESDIR}/${P}-cc.patch"
+)
+
+src_prepare() {
+       default
+       use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+       eautoreconf
+       tc-export CC RANLIB AR
+       export CC_FOR_BUILD=$(tc-getBUILD_CC)
+}
+
+src_configure() {
+       myconf=(
+               --without-tcl
+               --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+               --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+               $(use_with ldap)
+               $(use_with ssl)
+               $(use_with passfile passfile .pinepwd)
+               $(use_with kerberos krb5)
+               $(use_with threads pthread)
+               $(use_with spell interactive-spellcheck /usr/bin/aspell)
+               $(use_enable nls)
+               $(use_with ipv6)
+               $(use_with smime)
+       )
+
+       if use ssl; then
+               myconf+=(
+                       --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+                       --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+                       --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+               )
+       fi
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+       if use onlyalpine ; then
+               dobin alpine/alpine
+               doman doc/man1/alpine.1
+       else
+               emake -j1 DESTDIR="${D}" install
+               doman doc/man1/*.1
+       fi
+
+       dodoc NOTICE README*
+
+       if use doc ; then
+               dodoc doc/brochure.txt
+
+               dodoc -r doc/tech-notes/
+               newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+               newdoc "${S}/doc/mime.types" mime.types.sample
+               docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+       fi
+}
index 155fe030ffa001ec37ca22eb8926d8b1e31ebcd5..f37867c6e471896b1fc288c222ff98458248b331 100644 (file)
@@ -10,6 +10,8 @@
                <name>Proxy Maintainers</name>
        </maintainer>
        <use>
+               <flag name="chappa">enhance Alpine by applying Eduardo Chappa's
+                       patches</flag>
                <flag name="onlyalpine">installs only the alpine binary, so it does
                        not collied with pico and/or pine</flag>
                <flag name="passfile">Adds support for caching passwords into a file