dev-ruby/netrc: Add ruby21
authorPeter Wilmott <p8952@gentoo.org>
Thu, 13 Aug 2015 17:47:56 +0000 (18:47 +0100)
committerPeter Wilmott <p8952@gentoo.org>
Thu, 13 Aug 2015 17:53:53 +0000 (18:53 +0100)
Package-Manager: portage-2.2.20.1

dev-ruby/netrc/netrc-0.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/netrc/netrc-0.9.0-r1.ebuild b/dev-ruby/netrc/netrc-0.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..cd39914
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="changelog.txt Readme.md"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This library reads and writes .netrc files"
+HOMEPAGE="https://github.com/geemus/netrc"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+       sed -e '/test_encrypted_roundtrip/a skip "depends on external gpg test keys"' -i test/test_netrc.rb || die
+}
+
+each_ruby_test() {
+       ${RUBY} -S testrb test/test_*.rb || die
+}