media-sound/pamix: Bumped live ebuild to EAPI-7
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 10:25:04 +0000 (12:25 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 10:25:57 +0000 (12:25 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-sound/pamix/pamix-9999.ebuild

index a3da8fcc45fea6eb56eecc13900feeb2fc0e0c91..b4f4397507df85b298579a130eecb4f34772e5c3 100644 (file)
@@ -1,12 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-SCM=""
-[[ "${PV}" == 9999 ]] && SCM="git-r3"
-inherit cmake-utils ${SCM}
-unset SCM
+inherit cmake-utils
+
+if [[ "${PV}" == 9999 ]] ; then
+       inherit git-r3
+fi
 
 DESCRIPTION="A PulseAudio NCurses mixer"
 HOMEPAGE="https://github.com/patroclos/PAmix"
@@ -24,9 +25,10 @@ fi
 
 RDEPEND="media-sound/pulseaudio
        sys-libs/ncurses:0=[unicode?]"
-DEPEND="sys-devel/autoconf-archive
+DEPEND="${RDEPEND}"
+BDEPEND="
        virtual/pkgconfig
-       ${RDEPEND}"
+"
 
 src_configure() {
        local mycmakeargs=(