dev-libs/sink: 0.7.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 11 Oct 2018 18:53:22 +0000 (20:53 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 11 Oct 2018 19:02:12 +0000 (21:02 +0200)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-libs/sink/Manifest
dev-libs/sink/sink-0.7.0.ebuild [new file with mode: 0644]

index 1bbca381387bd3eb4969378cd719ff04251dad85..66068870c71ff036095ac98241c06f1e856b6d75 100644 (file)
@@ -1 +1,2 @@
 DIST sink-0.5.0.tar.gz 330203 BLAKE2B 5b0448dfb984c1aa4bdb913f8ce5e5e4e3f1a6ee33d840ed3d9fdf9e0ea6003a928970d2e6dc25e824241768da9abed7dce31ef857e4986990aad16e7aecd667 SHA512 e47f3d99b934abb184a5f8293f1a092fccabe0bb550573cd8c35918471a4caa94eaaec0361c43376c93cdb480612dd0f78626d6649077f777c5cccc8c5d4389f
+DIST sink-0.7.0.tar.gz 383090 BLAKE2B b853609889ead6f623c7288b9dfe8dba0388dc0d5e8f28d9967fa9be1d78b10bafd9d4674f11355bfe60506843d2abe033149c448ff293329db558ed00fef18b SHA512 591838cb9c76d89c1794b94b02bff3d67155e1f27ae32b7ac9369d15aa109130c7792f30e74b61009765e7b7cb78141bf5e3c93304d814bce22bf91059339fd0
diff --git a/dev-libs/sink/sink-0.7.0.ebuild b/dev-libs/sink/sink-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..c2e8a3d
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false" # build breaks otherwise. tests not isolated.
+inherit kde5
+
+DESCRIPTION="A data access layer handling synchronization, caching and indexing"
+SRC_URI="https://github.com/KDE/sink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# qtgui is bogus but is required because something else in the deptree
+# uses it as a public dependency but doesn't search for it properly
+RDEPEND="
+       $(add_frameworks_dep kcoreaddons)
+       $(add_kdeapps_dep kcalcore)
+       $(add_kdeapps_dep kcontacts)
+       $(add_kdeapps_dep kmime)
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtnetwork)
+       dev-db/lmdb:=
+       dev-libs/flatbuffers
+       dev-libs/kasync
+       >=dev-libs/xapian-1.4.4:0=
+       net-libs/kdav2
+       net-libs/kimap2
+       net-misc/curl
+       sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}
+       $(add_qt_dep qtconcurrent)
+"
+
+# fails to build
+RESTRICT+=" test"
+
+src_prepare() {
+       kde5_src_prepare
+       # FIXME: sink is useless without its 'examples'. Workaround our eclass
+       sed -i -e "/add_subdirectory(examples)/ s/#DONOTCOMPILE //" \
+               CMakeLists.txt || die "Failed to fix CMakeLists.txt"
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_DISABLE_FIND_PACKAGE_Libgit2=ON
+       )
+       kde5_src_configure
+}