app-text/mandoc: Fixed build with make-4.3
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 23 Jan 2020 15:32:19 +0000 (16:32 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 23 Jan 2020 15:32:59 +0000 (16:32 +0100)
Closes: https://bugs.gentoo.org/706024
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-text/mandoc/mandoc-1.14.5.ebuild

index 029a69eeadc917c93a53dd76b8bd0d9f4e5b32c5..5fdb433abdbd79d6370a02e354ee17500f2a069f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -28,6 +28,13 @@ src_prepare() {
                -e '/^db-install:/s:$: base-install:' \
                Makefile || die
 
+       # make-4.3 doesn't like the CC line (bug #706024)
+       # and "echo -n" is not portable
+       sed \
+               -e "s@^\(CC=\).*\$@\1\"$(tc-getCC)\"@" \
+               -e 's@echo -n@printf@g' \
+               -i configure || die
+
        cat <<-EOF > "configure.local"
                PREFIX="${EPREFIX}/usr"
                BINDIR="${EPREFIX}/usr/bin"