net-im/skypeforlinux: Bump to 8.46.0.60
authorDavid Seifert <soap@gentoo.org>
Wed, 5 Jun 2019 09:24:06 +0000 (11:24 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 5 Jun 2019 09:27:20 +0000 (11:27 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild [new file with mode: 0644]

index cbf7ea520d6846a7333094567e086b9810295c33..34d3c6bb96d9ee236c8c36b2119126434669c43b 100644 (file)
@@ -1 +1,2 @@
 DIST skypeforlinux_8.45.0.41-1.x86_64.rpm 98085869 BLAKE2B 6ade91a30ce302adc0b1437508ccddad6505c97f5d26a8fc6afbf2a1670a201e450a158e5ba786e4a48f444482304bf19aa869990b7aad5aac1c56af8e338c73 SHA512 af1ff07cabce98058c7b9ca11456f57da2b49dd1c89cd12add03954e2ff7e591cc8254c9146c7b5137c414769357b7f57ff370a7803fa1b17ba34c4a87bb5ef2
+DIST skypeforlinux_8.46.0.60-1.x86_64.rpm 98406332 BLAKE2B 96cb9ce76ec5278254fa2891a82b66481d1dbbc75cde7f51fd9dab7cd681ccd5c34c5777c0e639166c2268e03b58fcc844961b589f8248b68374f17bec516a41 SHA512 679ef60427fc5435d14e54eea4bebdb93909dbab8aa7803994fa8fa9077a73c3b2366ea120a80a9a12aa5a23ee5e8a34b67232850686f6350a69e13fc5bce41a
diff --git a/net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild b/net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild
new file mode 100644 (file)
index 0000000..df39845
--- /dev/null
@@ -0,0 +1,102 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+       || (
+               sys-auth/elogind
+               sys-apps/systemd
+       )
+       app-crypt/libsecret[${MULTILIB_USEDEP}]
+       dev-libs/atk[${MULTILIB_USEDEP}]
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       dev-libs/nspr[${MULTILIB_USEDEP}]
+       dev-libs/nss[${MULTILIB_USEDEP}]
+       media-libs/alsa-lib[${MULTILIB_USEDEP}]
+       media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+       media-libs/freetype:2[${MULTILIB_USEDEP}]
+       media-libs/libv4l[${MULTILIB_USEDEP}]
+       net-print/cups[${MULTILIB_USEDEP}]
+       sys-apps/dbus[${MULTILIB_USEDEP}]
+       sys-devel/gcc[cxx]
+       virtual/ttf-fonts
+       x11-libs/cairo[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+       x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+       x11-libs/libXcursor[${MULTILIB_USEDEP}]
+       x11-libs/libXdamage[${MULTILIB_USEDEP}]
+       x11-libs/libXext[${MULTILIB_USEDEP}]
+       x11-libs/libXfixes[${MULTILIB_USEDEP}]
+       x11-libs/libXi[${MULTILIB_USEDEP}]
+       x11-libs/libXrandr[${MULTILIB_USEDEP}]
+       x11-libs/libXrender[${MULTILIB_USEDEP}]
+       x11-libs/libXtst[${MULTILIB_USEDEP}]
+       x11-libs/libxcb[${MULTILIB_USEDEP}]
+       x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+       x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -e "/^OnlyShowIn=/d" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       dodir /opt
+       cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+       dobin usr/bin/skypeforlinux
+
+       dodoc usr/share/skypeforlinux/*.html
+       dodoc -r usr/share/doc/skypeforlinux/.
+       # symlink required for the "Help->3rd Party Notes" menu entry  (otherwise frozen skype -> xdg-open)
+       dosym ${PF} usr/share/doc/skypeforlinux
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       if use pax_kernel; then
+               pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+               pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+               ewarn "You have set USE=pax_kernel meaning that you intend to run"
+               ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+               ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+               ewarn "you suspect that ${PN} is being broken by this modification,"
+               ewarn "please open a bug."
+       fi
+}