dev-python/wxpython: Revert "Remove old"
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 13:57:12 +0000 (15:57 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 13:58:22 +0000 (15:58 +0200)
Reverts: d3a96db326aded10b322dbd2c9da409caa405c7d
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/wxpython/Manifest
dev-python/wxpython/wxpython-4.0.6.ebuild [new file with mode: 0644]

index c4e1500ef0a6558d81cc43ee3acc5a29ba526648..e88e0da4316eb4575e6053d2155bbb16216ae842 100644 (file)
@@ -1,3 +1,4 @@
+DIST wxPython-4.0.6.tar.gz 68815031 BLAKE2B 49367f5d0867c28893c43d54c4ad6001807bdc95d81327082e3c88fd796e5e2daafcf6b70252828bdcfaaec8b42ba64e881575d209eb4f61a85f58ebd79e8ae4 SHA512 bfe799e1a0987cb57f2e31199cdb522471aaa08bb3b642fdf4130f4219b81487d4b6252f7a8afd3af7cdaeef2e992cecfc581e97d8b42307a4e0a8c9009db301
 DIST wxPython-4.0.7.post2.tar.gz 68891167 BLAKE2B 77eb69f7a59e5be81c3d17b64c76e09a43efc9226bd87fd058483185871a95ce05dbb65614ec8b003edf52cbe1cb1a115856c0d622170c51ecacbb952106fe22 SHA512 7af89db90a0f7e6b644d61c1ede01ec36a2c295e46d44692ae9dbc4af923310c1b498a52f45b02a89e8917d844c6abe67e5f3fdd9c1d51da3312899319a349e4
 DIST wxPython-demo-3.0.2.0.tar.bz2 3992212 BLAKE2B 9defe133e3863be5ae07b7adb4bcb94688487e9dd9f5ab1f768d2f5942f30d05ff678f1ba74241d9bafde3584e3c68ffeae4978117aaa300e23165140e6a6d44 SHA512 361ecaa7dfe5bae0757e04215c564370eaf8e5260ead45007f9d70439c15701725c3cbcd76691a5191258bef24fd200ebd61347a3fd920d888137bfc98a16702
 DIST wxPython-src-3.0.2.0.tar.bz2 58304944 BLAKE2B 1144acf2cfa0a18aa2f90aabe81aaeca54d3fe6139818267dbc031accbae38035478a64ec084fe8bb8b89126fb70ff96e68981026df8ad3fc82e81c6d0e22d1a SHA512 a3798e89ff19344253aac7d771971e519f7fa9723e82bd97e98f16fd7f1572e513170b02295b872dae0b1ae3fa95efc4ef34d078045b839694b4fdad3a27c9e4
diff --git a/dev-python/wxpython/wxpython-4.0.6.ebuild b/dev-python/wxpython/wxpython-4.0.6.ebuild
new file mode 100644 (file)
index 0000000..b0dffbe
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# wxPython 4 supports python 2.7, but because it's going EOL soon and to ease
+# transition from wxPython 3.x, we make this package py3-only.
+PYTHON_COMPAT=( python3_{6,7} )
+WX_GTK_VER="3.0-gtk3"
+
+inherit distutils-r1 multiprocessing virtualx wxwidgets
+
+MY_PN="wxPython"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+# wxPython doesn't seem to be able to optionally disable features. webkit is
+# optionally patched out because it's so huge, but other elements are not,
+# which makes us have to require all features from wxGTK
+RDEPEND="
+       >=x11-libs/wxGTK-3.0.4-r301:${WX_GTK_VER}=[gstreamer,libnotify,opengl,sdl,tiff,webkit?,X]
+       media-libs/libpng:0=
+       media-libs/tiff:0
+       virtual/jpeg:0"
+
+DEPEND="${RDEPEND}
+       app-doc/doxygen
+       dev-python/pathlib2[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       test? (
+               ${VIRTUALX_DEPEND}
+               dev-python/appdirs[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"
+)
+
+python_prepare_all() {
+       if ! use webkit; then
+               eapply "${FILESDIR}/${PN}-4.0.6-no-webkit.patch"
+               rm unittests/test_webview.py || die
+       fi
+       # Most of these tests disabled below fail because of the virtx/portage
+       # environment, but some fail for unknown reasons.
+       rm unittests/test_uiaction.py \
+               unittests/test_notifmsg.py \
+               unittests/test_mousemanager.py \
+               unittests/test_display.py \
+               unittests/test_pi_import.py \
+               unittests/test_lib_agw_thumbnailctrl.py \
+               unittests/test_sound.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+src_configure() {
+       setup-wxwidgets
+}
+
+python_compile() {
+       DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+       ${PYTHON} build.py build_py \
+               --use_syswx \
+               --no_magic \
+               --jobs=$(makeopts_jobs) \
+               --release || die
+}
+
+python_install() {
+       distutils-r1_python_install --skip-build
+}
+
+python_test() {
+       virtx pytest -vv unittests
+}