sys-devel/patch: Drop old
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 23 Aug 2019 10:26:40 +0000 (13:26 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 23 Aug 2019 10:26:40 +0000 (13:26 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-devel/patch/patch-2.7.6-r3.ebuild [deleted file]

diff --git a/sys-devel/patch/patch-2.7.6-r3.ebuild b/sys-devel/patch/patch-2.7.6-r3.ebuild
deleted file mode 100644 (file)
index 6efd863..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-DESCRIPTION="Utility to apply diffs to files"
-HOMEPAGE="https://www.gnu.org/software/patch/patch.html"
-SRC_URI="mirror://gnu/patch/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static test xattr"
-
-RDEPEND="xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}
-       test? ( sys-apps/ed )"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-fix-test-suite.patch
-       "${FILESDIR}"/${PN}-2.7.6-fix-error-handling-with-git-style-patches.patch
-       "${FILESDIR}"/${PN}-2.7.6-CVE-2018-6951.patch
-       "${FILESDIR}"/${PN}-2.7.6-allow-input-files-to-be-missing-for-ed-style-patches.patch
-       "${FILESDIR}"/${PN}-2.7.6-CVE-2018-1000156.patch
-       "${FILESDIR}"/${PN}-2.7.6-CVE-2018-6952.patch
-)
-
-src_configure() {
-       use static && append-ldflags -static
-
-       local myeconfargs=(
-               $(use_enable xattr)
-               --program-prefix="$(use userland_BSD && echo g)"
-       )
-       # Do not let $ED mess up the search for `ed` 470210.
-       ac_cv_path_ED=$(type -P ed) \
-       econf "${myeconfargs[@]}"
-}