net-p2p/amule: Add missing readline dep to live ebuild
authorAlexander Tsoy <alexander@tsoy.me>
Wed, 29 Apr 2020 16:59:16 +0000 (19:59 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 30 Apr 2020 11:59:55 +0000 (14:59 +0300)
Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-p2p/amule/amule-9999.ebuild

index f14cc28e5c40a87ebfede6f4dba2cffc6d7ecf57..a108c9752909fcdf26dde6e870f3362a6672aca1 100644 (file)
@@ -27,6 +27,7 @@ RDEPEND="
        dev-libs/boost:=
        dev-libs/crypto++:=
        sys-libs/binutils-libs:0=
+       sys-libs/readline:0=
        sys-libs/zlib
        >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X?]
        daemon? ( acct-user/amule )
@@ -42,8 +43,10 @@ RDEPEND="
 DEPEND="${RDEPEND}
        X? ( dev-util/desktop-file-utils )
 "
-BDEPEND="virtual/pkgconfig
-       nls? ( sys-devel/gettext )"
+BDEPEND="
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+"
 
 PATCHES=(
 )
@@ -55,7 +58,7 @@ pkg_setup() {
 src_prepare() {
        default
 
-       if [[ "${PV}" == *9999 ]]; then
+       if [[ ${PV} == 9999 ]]; then
                ./autogen.sh || die
        fi
 }