dev-python/smmap: Bump to 3.0.4
authorMichał Górny <mgorny@gentoo.org>
Tue, 5 May 2020 05:33:25 +0000 (07:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 5 May 2020 07:15:04 +0000 (09:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/smmap/Manifest
dev-python/smmap/smmap-3.0.4.ebuild [new file with mode: 0644]

index 640e291ac3e6698818351b71cd8810eaf56cb9d1..dccb44ca68a33c6c962a0465c19e8778a8056fba 100644 (file)
@@ -1 +1,2 @@
 DIST smmap-3.0.2.tar.gz 22511 BLAKE2B 26aa528628d9f923b883481e635292c7eeba70d37c8258dd242a5ff875ec4627c57c753e4ce72de6d19ef7227540689b6c410d941079ef5c1b279c30f65e50a0 SHA512 52db538f16b9d0bdbbb932c7eb67510facd0638ea69dec21e9d503c3381195130ac0bc1f48db24ca76b8e31b07279799a767dd7e1bf1d755e7f7684f3285b8da
+DIST smmap-3.0.4.tar.gz 22459 BLAKE2B daccd2cfa4d448297d1a0b2c33c1a316e8c84ae5dbe934d688fbdf034a660214c98d428206b8e9ce1cab3e5f3561309a1e7f29e3371b7358954f0fe7ea37092d SHA512 da7e5c0257f29b487eb5ee18f29656340f7f6999dd625d93560444d526df8036a8fc4452242a2d01203907798709d82a0015709e097bc22acd3d0a8b976ef9fe
diff --git a/dev-python/smmap/smmap-3.0.4.ebuild b/dev-python/smmap/smmap-3.0.4.ebuild
new file mode 100644 (file)
index 0000000..73277c5
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+       https://pypi.org/project/smmap/
+       https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest