media-sound/lilypond: fix sed invocation.
authorKarl Linden <karl.j.linden@gmail.com>
Sun, 26 Nov 2017 18:51:36 +0000 (19:51 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 30 Nov 2017 14:46:00 +0000 (15:46 +0100)
Closes: https://bugs.gentoo.org/629496
Package-Manager: Portage-2.3.16, Repoman-2.3.6

media-sound/lilypond/lilypond-2.18.2-r3.ebuild
media-sound/lilypond/lilypond-2.19.80.ebuild
media-sound/lilypond/lilypond-9999.ebuild

index 4afc18c6e1d6f062e954a478dfd1d3c589c998f4..ee3ea59a82a8cb2ca9f410b558805fbe77113618 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -80,7 +80,7 @@ src_prepare() {
        done
 
        # respect AR
-       sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+       sed -i "s:^AR=ar:AR=$(tc-getAR):" stepmake/stepmake/library-vars.make || die
 
        # remove bundled texinfo file (fixes bug #448560)
        rm tex/texinfo.tex || die
index 5dd683dc41864e2d5fdd0652e19baee83b442271..3fae42dbe7e25bdde19cdf94bb0c43fe29d04487 100644 (file)
@@ -85,7 +85,7 @@ src_prepare() {
        done
 
        # respect AR
-       sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+       sed -i "s:^AR=ar:AR=$(tc-getAR):" stepmake/stepmake/library-vars.make || die
 
        # remove bundled texinfo file (fixes bug #448560)
        rm tex/texinfo.tex || die
index 5dd683dc41864e2d5fdd0652e19baee83b442271..3fae42dbe7e25bdde19cdf94bb0c43fe29d04487 100644 (file)
@@ -85,7 +85,7 @@ src_prepare() {
        done
 
        # respect AR
-       sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+       sed -i "s:^AR=ar:AR=$(tc-getAR):" stepmake/stepmake/library-vars.make || die
 
        # remove bundled texinfo file (fixes bug #448560)
        rm tex/texinfo.tex || die