dev-python/ipaddr: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 4 Aug 2018 15:00:58 +0000 (17:00 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 5 Aug 2018 13:52:46 +0000 (15:52 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/ipaddr/Manifest
dev-python/ipaddr/ipaddr-2.2.0.ebuild [new file with mode: 0644]

index a3fe3ad450e33cae9f9df6279f0abbba1955cf57..0ff11febdd8577581e1cfdbe1adcfefcd454be4d 100644 (file)
@@ -1 +1,2 @@
 DIST ipaddr-2.1.11.tar.gz 29046 BLAKE2B 8196898209d580ce25bc2ccb05b2e772c42c053116749bb5137a87b6648472c4fab522d76405510cb2304859b4179c593b213739e9294a1af1d9894cac7040ab SHA512 a97b0f760f0d7fac549e5edf17b644c966a8858c145b8f9472ddc8bf4805c9d537f6f8755e3716d78b729b87e84149f8b73c7f98c0deee4fbf266ccb7a206bc6
+DIST ipaddr-2.2.0.tar.gz 26266 BLAKE2B f12807beb52c5cb3c7da2afa4b61b264fb58f0100900e5ca062127ce218f9f5710f38ac7c7183a7aa08b77757c39866d169e6e39c3bc5c6c55df003a9b414ec0 SHA512 5adb117c44e6e5dbdb9e96543aa7a34f35b4a4ec9baa163a25448058c34091bf4019d24f0250928291e4d4bc97dcdf75865daef739e2d94f98cc584e6e6c50dd
diff --git a/dev-python/ipaddr/ipaddr-2.2.0.ebuild b/dev-python/ipaddr/ipaddr-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..ed6a948
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="https://github.com/google/ipaddr-py https://pypi.org/project/ipaddr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare() {
+       if python_is_python3; then
+               2to3 -n -w --no-diffs *.py || die
+       fi
+}
+
+python_test() {
+       distutils_install_for_testing
+       "${EPYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}