old
authorMike Frysinger <vapier@gentoo.org>
Sat, 24 Mar 2007 08:17:31 +0000 (08:17 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 24 Mar 2007 08:17:31 +0000 (08:17 +0000)
app-shells/bash/bash-3.2_p15.ebuild [deleted file]
app-shells/bash/files/digest-bash-3.2_p15 [deleted file]

diff --git a/app-shells/bash/bash-3.2_p15.ebuild b/app-shells/bash/bash-3.2_p15.ebuild
deleted file mode 100644 (file)
index 9e4aff6..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p15.ebuild,v 1.2 2007/03/23 15:57:24 uberlord Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.2
-READLINE_PLEVEL=0 # both readline patches are also released as bash patches
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-#              printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
-#                      ${MY_PV} ${MY_PV/\.} ${i}
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
-       ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
-       $(for ((i=1; i<=PLEVEL; i++)); do
-               printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
-                       ${MY_PV} ${MY_PV/\.} ${i}
-       done)
-       $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
-               printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${READLINE_VER} ${READLINE_VER/\.} ${i}
-               printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${READLINE_VER} ${READLINE_VER/\.} ${i}
-       done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="afs bashlogger nls vanilla"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
-       unpack ${MY_P}.tar.gz
-       cd "${S}"
-
-       # Include official patches
-       local i
-       for ((i=1; i<=PLEVEL; i++)); do
-               epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
-       done
-       cd lib/readline
-       for ((i=1; i<=READLINE_PLEVEL; i++)); do
-               epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
-       done
-       cd ../..
-
-       if ! use vanilla ; then
-               epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
-               # Fix process substitution on BSD.
-               epatch "${FILESDIR}"/${PN}-3.2-process-subst.patch
-
-               epatch "${FILESDIR}"/${PN}-3.2-ulimit.patch
-               # Don't barf on handled signals in scripts
-               epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
-               epatch "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch #131875
-               # Log bash commands to syslog #91327
-               if use bashlogger ; then
-                       echo
-                       ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
-                       ewarn "This will log ALL output you enter into the shell, you have been warned."
-                       ebeep
-                       epause
-                       epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
-               fi
-       fi
-
-       epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-}
-
-src_compile() {
-       filter-flags -malign-double
-
-       local myconf=
-
-       # Always use the buildin readline, else if we update readline
-       # bash gets borked as readline is usually not binary compadible
-       # between minor versions.
-       #myconf="${myconf} $(use_with !readline installed-readline)"
-       myconf="${myconf} --without-installed-readline"
-
-       # Don't even think about building this statically without
-       # reading Bug 7714 first.  If you still build it statically,
-       # don't come crying to use with bugs ;).
-       #use static && export LDFLAGS="${LDFLAGS} -static"
-       use nls || myconf="${myconf} --disable-nls"
-
-       # Force linking with system curses ... the bundled termcap lib
-       # sucks bad compared to ncurses
-       myconf="${myconf} --with-curses"
-
-       econf \
-               $(use_with afs) \
-               --disable-profiling \
-               --without-gnu-malloc \
-               ${myconf} || die
-       emake -j1 || die "make failed"  # see bug 102426
-}
-
-src_install() {
-       einstall || die
-
-       dodir /bin
-       mv "${D}"/usr/bin/bash "${D}"/bin/
-       dosym bash /bin/rbash
-
-       insinto /etc/bash
-       doins "${FILESDIR}"/{bashrc,bash_logout}
-       insinto /etc/skel
-       for f in bash{_logout,_profile,rc} ; do
-               newins "${FILESDIR}"/dot-${f} .${f}
-       done
-
-       sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
-       sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
-
-       doman doc/*.1
-       dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
-       dosym bash.info /usr/share/info/bashref.info
-}
-
-pkg_preinst() {
-       if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
-               mkdir -p "${ROOT}"/etc/bash
-               mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
-       fi
-
-       # our bash_logout is just a place holder so dont
-       # force users to go through etc-update all the time
-       if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
-               rm -f "${D}"/etc/bash/bash_logout
-       fi
-
-       # If /bin/sh does not exist or is bash, then provide it
-       # Otherwise leave it alone
-       if [[ ! -e ${ROOT}/bin/sh ]] ; then
-               ln -s bash "${ROOT}"/bin/sh
-       elif [[ -L ${ROOT}/bin/sh ]] ; then
-               case "$(readlink "${ROOT}"/bin/sh)" in
-                       bash|/bin/bash) cp -pPR "${ROOT}"/bin/sh "${D}"/bin/ ;;
-               esac
-       fi
-}
diff --git a/app-shells/bash/files/digest-bash-3.2_p15 b/app-shells/bash/files/digest-bash-3.2_p15
deleted file mode 100644 (file)
index 7a1320a..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-MD5 00bfa16d58e034e3c2aa27f390390d30 bash-3.2.tar.gz 2529838
-RMD160 a73f790817d98be375a36def567737498e33aaf1 bash-3.2.tar.gz 2529838
-SHA256 26c99025b59e30779300b68adb764f824974d267a4d7cc1b347d14a2393f9fb4 bash-3.2.tar.gz 2529838
-MD5 d8e10c754f477e3f3a581af566b89301 bash32-001 1539
-RMD160 633f6eb6b2b48345234c442b835abb94d10e0dad bash32-001 1539
-SHA256 beda60ce6186fafa36cd0a98db9ced42cff68daee4342cca73167fb0f2f43eaa bash32-001 1539
-MD5 d38a5288b2f0ea6c9ac76b66cc74ef7d bash32-002 1524
-RMD160 5d0f0dab859197784b15c683d54e7a505a8434c3 bash32-002 1524
-SHA256 a0ca49a3c47678ad074c990bdc871fcec680749b7f04f2def6527f04c589c40a bash32-002 1524
-MD5 0b90d37911827d8cb95f3b4353cc225e bash32-003 4599
-RMD160 efdcb4f8d6c800b5a3dab7bae37f95861bf186d8 bash32-003 4599
-SHA256 7ec9e5e7e402e43b12bfd3a9237f4f171029fc7f58e59335abf3ccb455a5a84d bash32-003 4599
-MD5 8062f3a59631f58d78b180d83759b68a bash32-004 2585
-RMD160 0ec49a8b414f283aefc00c5ee63de913c96a7a21 bash32-004 2585
-SHA256 3de0938673637089c3b0f0f355de377bb2be2d3fca68053dda267ca11b5998f2 bash32-004 2585
-MD5 585b5943fadf0875ced243b245adde58 bash32-005 5910
-RMD160 8597b22136a294dc2cf1103a5c9ab100b75d16f5 bash32-005 5910
-SHA256 e7fecdecb12320cd6fe9aca83fab1828b76aeb5313b991883764cb9139d845b7 bash32-005 5910
-MD5 1d5732e01ea938aeed42f3def131fa4d bash32-006 1298
-RMD160 d8193a69956064e9fb4e64e13132b1c1b2cb8d43 bash32-006 1298
-SHA256 8f14f81ced32bc057bc10abf6842f4a5ac172816631f2b87a5a3be4f01c0847d bash32-006 1298
-MD5 dcd0cc5d801607827f7c851e72b0eabc bash32-007 1375
-RMD160 332cb936851e156c9231236541b78e651fd4ab5a bash32-007 1375
-SHA256 6863a712e5a68eccfb77162a9f947ffd80af648f0124c38f795ebba2be12eff8 bash32-007 1375
-MD5 bb3c7dd11198c0ab93d0e960bebf6256 bash32-008 1302
-RMD160 44558cabad6b05a53217c17419c2477a29ebe7da bash32-008 1302
-SHA256 ccf303b4d199d89d5efc659235f8a645376e86d294260dda4becbb61ec06667b bash32-008 1302
-MD5 434a6f29b0ca5f1ab784b2437ae8eaed bash32-009 1882
-RMD160 5a20bc86d04a156cdbcb22f36b6c68c7318e9bab bash32-009 1882
-SHA256 ef30c579419106b4b4a2d0064ef7e57ceee6cdf657f4ccd7b89c8e4fd70560d8 bash32-009 1882
-MD5 2efff04dd246fcf63bd4b99f77c9a081 bash32-010 6293
-RMD160 51b4c18b7939f663ee72861a522d7fb1d1afaa30 bash32-010 6293
-SHA256 bb7df9fefe88d62ee371353edf62402a667cffba6ea202aa1c8b220308a0c612 bash32-010 6293
-MD5 1dd104342f6920dfaf5efb3131e922e0 bash32-011 4776
-RMD160 030404aabf09b8aa295f241d1d96bdba12a1f8cb bash32-011 4776
-SHA256 85bf656cfc49b1447b061341a4b1cb93ba89a41d8d1699a65aa971d1853ba472 bash32-011 4776
-MD5 4f24b696ab78bdfae4f9cb7eb59b835d bash32-012 2555
-RMD160 c2011d3d8a8004acd58112568e611511f9bde5ff bash32-012 2555
-SHA256 45ef4ad98f2f218aa3acec15842ae1b833769c1dbe2f90c9bba00bbe4949fc43 bash32-012 2555
-MD5 7c40addbf1187a26ae1c8373ed383442 bash32-013 1852
-RMD160 4ddfeafea7e451376c56d17836079a963298df06 bash32-013 1852
-SHA256 9fbf893c383f45d25e5bc5c9eae8d2b349521f288945b3bd21c781784b81f693 bash32-013 1852
-MD5 28e88c9f8679e99ac590d4a4a8227c56 bash32-014 8141
-RMD160 cf47a705b00039bdc2cc5cd37dd20a58b029af33 bash32-014 8141
-SHA256 62bb1a4d70f6f7938ca70a6aa7fe6f4b377ab5f450c7756b22b41de3bbd98ed6 bash32-014 8141
-MD5 7c17d29675bd0d49470f162774385f80 bash32-015 2293
-RMD160 6535eb24b8d30ce9756b1e7c0d21c0946b1d354e bash32-015 2293
-SHA256 de40425e83628eb7431f39340ac09b42b5fcf484a565352851961b3e917d8771 bash32-015 2293