net-misc/iputils: update live ebuild
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 19 Jul 2019 11:01:51 +0000 (13:01 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 19 Jul 2019 11:01:51 +0000 (13:01 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/iputils/iputils-99999999.ebuild

index 4e19ac8bb2b2bea288a82238e4109118dbc0149e..ffc2311cad4e14ce19c9f8b97635133b8e76a118 100644 (file)
@@ -7,7 +7,7 @@
 # To regenerate man/html pages emerge iputils-99999999[doc] with
 # EGIT_COMMIT set to release tag and tar ${S}/doc folder.
 
-EAPI="6"
+EAPI="7"
 
 PLOCALES="ja"
 
@@ -29,6 +29,11 @@ LICENSE="BSD GPL-2+ rdisc"
 SLOT="0"
 IUSE="+arping caps clockdiff doc gcrypt idn ipv6 libressl nettle nls rarpd rdisc SECURITY_HAZARD ssl static tftpd tracepath traceroute6"
 
+BDEPEND="
+       virtual/os-headers
+       virtual/pkgconfig
+"
+
 LIB_DEPEND="
        caps? ( sys-libs/libcap[static-libs(+)] )
        idn? ( net-dns/libidn2:=[static-libs(+)] )
@@ -53,12 +58,12 @@ RDEPEND="
        traceroute6? ( !net-analyzer/traceroute )
        !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
 "
+
 DEPEND="
        ${RDEPEND}
        static? ( ${LIB_DEPEND} )
-       virtual/os-headers
-       virtual/pkgconfig
 "
+
 if [[ ${PV} == "99999999" ]] ; then
        DEPEND+="
                app-text/docbook-xml-dtd:4.2
@@ -160,7 +165,6 @@ src_install() {
                local -a man_pages
                local -a html_man_pages
 
-               local oifs=${IFS}
                while IFS= read -r -u 3 -d $'\0' my_bin
                do
                        my_bin=$(basename "${my_bin}")
@@ -174,7 +178,6 @@ src_install() {
                                html_man_pages+=( ${my_bin}.html )
                        fi
                done 3< <(find "${ED%/}"/{bin,usr/bin,usr/sbin} -type f -perm -a+x -print0 2>/dev/null)
-               IFS=${oifs}
 
                pushd doc &>/dev/null || die
                doman "${man_pages[@]}"