app-leechcraft/lc-ooronee: Use optfeature from eutils.eclass
authorJustin Lecher <jlec@gentoo.org>
Sat, 12 Sep 2015 10:33:07 +0000 (12:33 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sat, 12 Sep 2015 10:33:07 +0000 (12:33 +0200)
Package-Manager: portage-2.2.20
RepoMan-Options: --force
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-leechcraft/lc-ooronee/lc-ooronee-0.6.65.ebuild
app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild
app-leechcraft/lc-ooronee/lc-ooronee-9999.ebuild

index f49cc760167d2e74f9b2b7cb12cfd504bac91c7e..88749dca7eceed9d7a770c0a1ba2dd0e159161ea 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI="5"
 
-inherit leechcraft
+inherit eutils leechcraft
 
 DESCRIPTION="Quark handling text and images droppend onto it"
 
@@ -17,20 +17,6 @@ RDEPEND="${DEPEND}
        virtual/leechcraft-quark-sideprovider
 "
 
-# Grabbed from net-misc/netctl ebuild.
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 to ${desc}"
-               else
-                       elog "  [ ] $1 to ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        elog "Install at least some of the following additional LeechCraft modules for Ooronee to be useful:"
        optfeature "upload images" app-leechcraft/lc-imgaste app-leechcraft/lc-blasq
index f49cc760167d2e74f9b2b7cb12cfd504bac91c7e..88749dca7eceed9d7a770c0a1ba2dd0e159161ea 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI="5"
 
-inherit leechcraft
+inherit eutils leechcraft
 
 DESCRIPTION="Quark handling text and images droppend onto it"
 
@@ -17,20 +17,6 @@ RDEPEND="${DEPEND}
        virtual/leechcraft-quark-sideprovider
 "
 
-# Grabbed from net-misc/netctl ebuild.
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 to ${desc}"
-               else
-                       elog "  [ ] $1 to ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        elog "Install at least some of the following additional LeechCraft modules for Ooronee to be useful:"
        optfeature "upload images" app-leechcraft/lc-imgaste app-leechcraft/lc-blasq
index 6bcfcb00a9ce6d789be970c4c745dbf1e78361a0..ad510adbf77a0ac91bb4e20e453e7850506075b1 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI="5"
 
-inherit leechcraft
+inherit eutils leechcraft
 
 DESCRIPTION="Quark handling text and images droppend onto it"
 
@@ -17,20 +17,6 @@ RDEPEND="${DEPEND}
        virtual/leechcraft-quark-sideprovider
 "
 
-# Grabbed from net-misc/netctl ebuild.
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 to ${desc}"
-               else
-                       elog "  [ ] $1 to ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        elog "Install at least some of the following additional LeechCraft modules for Ooronee to be useful:"
        optfeature "upload images" app-leechcraft/lc-imgaste app-leechcraft/lc-blasq