dev-python/cliff-tablib: drop py34 support
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 7 Aug 2018 17:07:31 +0000 (13:07 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 7 Aug 2018 17:08:19 +0000 (13:08 -0400)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild b/dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild
new file mode 100644 (file)
index 0000000..c2af046
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output for the cliff framework"
+HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
+               dev-python/cliff[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+       # Use IUSE examples for installing the demoapp
+       use examples && local EXAMPLES=( demoapp/. )
+       use doc && local HTML_DOCS=( docs/build/html/. )
+       distutils-r1_python_install_all
+}