app-arch/xar-1.8-r3: fix compile during install
authorFabian Groffen <grobian@gentoo.org>
Sun, 3 Nov 2019 09:39:10 +0000 (10:39 +0100)
committerFabian Groffen <grobian@gentoo.org>
Sun, 3 Nov 2019 09:39:10 +0000 (10:39 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
app-arch/xar/xar-1.8-r3.ebuild

index 17416980f25148630093fe96409d8548cc543db7..2b1ae6a93b9c3a54d5c7b3411511becce4962151 100644 (file)
@@ -45,6 +45,12 @@ src_prepare() {
        # strip RPATH pointing to ED
        cd "${S}"/src || die
        sed -i -e 's/@RPATH@//' Makefile.inc.in || die
+
+       # avoid GNU make (bug?) behaviour of removing xar.o as intermediate
+       # file, this doesn't happen outside portage, but it does from the
+       # ebuild env, causing the install phase to re-compile xar.o and link
+       # the executable
+       echo ".PRECIOUS: @objroot@src/%.o" >> Makefile.inc.in || die
 }
 
 multilib_src_configure() {