media-gfx/gnome-screenshot: bump to 3.36.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 11:16:51 +0000 (14:16 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 11:17:58 +0000 (14:17 +0300)
Only translation updates over 3.34

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-gfx/gnome-screenshot/Manifest
media-gfx/gnome-screenshot/gnome-screenshot-3.36.0.ebuild [new file with mode: 0644]

index 12ca4b3e4525c0d9f4e57262b00fa20cf5c434fb..679c6df979f380e9706a1962f084dfbff11ed8d3 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-screenshot-3.32.0.tar.xz 228876 BLAKE2B a7f742cf67815428da3013db23d36b34f52bf99c3d77002cac9243d2f5c5c5c1828cb92a34e0541d18c57f357d39f876a815d7caa432f92704c749a431faae95 SHA512 2747f3cc6ff6df6db6d64c9c13f7d7e3c0bf738cdace2850869c1158d23d02dd03b55e6704c9540f1e5b789626ea07741a0030ce3b06dd70c09f2fb2afa79c61
+DIST gnome-screenshot-3.36.0.tar.xz 231420 BLAKE2B ce916d4d221252f47c84ebdec52ddcc2e25c2481df848cb6199842857c7ba537f56c22bdcb2a8e5b988d767fbc242d0c727119bc1ae9d569644eae15688aebf5 SHA512 fda599e7c50b37d8356352085b2f45f3b8c868af897352810998e127bd7333d5a1383369ec1cb980064f7e0aafa0e01bc5cdb31563ea56b1a7e4099fc18cc6b4
diff --git a/media-gfx/gnome-screenshot/gnome-screenshot-3.36.0.ebuild b/media-gfx/gnome-screenshot/gnome-screenshot-3.36.0.ebuild
new file mode 100644 (file)
index 0000000..9eca7cb
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Screenshot utility for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-screenshot"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# libcanberra 0.26-r2 is needed for gtk+:3 fixes
+DEPEND="
+       x11-libs/libX11
+       x11-libs/libXext
+       >=dev-libs/glib-2.35.1:2[dbus]
+       >=x11-libs/gtk+-3.12.0:3
+       >=media-libs/libcanberra-0.26-r2[gtk3]
+"
+RDEPEND="${DEPEND}
+       >=gnome-base/gsettings-desktop-schemas-0.1.0
+"
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-libs/libxml2:2
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       x11-base/xorg-proto
+"
+
+DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
+       non-interactive mode when launched from a terminal. If you want to choose
+       where to save the screenshot, run 'gnome-screenshot --interactive'"
+
+src_install() {
+       meson_src_install
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+       readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}