dev-python/duecredit: Version bump
authorAlexey Shvetsov <alexxy@gentoo.org>
Thu, 26 Dec 2019 07:27:37 +0000 (10:27 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Thu, 26 Dec 2019 07:27:37 +0000 (10:27 +0300)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-python/duecredit/Manifest
dev-python/duecredit/duecredit-0.7.0.ebuild [new file with mode: 0644]

index 970a265a466c54ea3d4e449cc4fcc19b528b8af3..1f0d3932854ea73ab12f6b460b46731cd78398c1 100644 (file)
@@ -1 +1,2 @@
 DIST duecredit-0.6.4.tar.gz 65763 BLAKE2B 590e5736a2a65153078a515fcba64dc3a34aa058311276a4144a40788140be563bf689956067a60179dcecd4b58b371c811dc9b50a0c7e21f6cf5d3193f2d17e SHA512 4a11c743be40c1ef14e73d06ba4434964f9a62f6c19c8aa18b337b1f37526e770e020e672bcef5fc920a64c2a0f2a0eccec6917ec172078c4d3ea24ec0e1683d
+DIST duecredit-0.7.0.tar.gz 66131 BLAKE2B 3f32c1a4e62d4650d6914f4e124907170a50d63900fbb009b870b3f9c9eace27b76500e655cb74caea0ce22cfadd62f81a84a438c1cb82092502661f1d4e0c03 SHA512 a32ead3e0710323d5ab3283a3b2d1cb03e03bf925f78fdb3b5182079851127b8b674492bd402667e57ec113d1ec05f9c3490642f8d0fba6a8f3ddfd706a052c1
diff --git a/dev-python/duecredit/duecredit-0.7.0.ebuild b/dev-python/duecredit/duecredit-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..fc106d6
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Publications (and donations) tracer"
+HOMEPAGE="https://github.com/duecredit/duecredit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+       ${RDEPEND}"