dev-lang/R: pull in LaTeX stuff for the test suite.
authorMichael Orlitzky <mjo@gentoo.org>
Tue, 28 Apr 2020 15:27:27 +0000 (11:27 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Tue, 28 Apr 2020 15:33:52 +0000 (11:33 -0400)
At least one test (reg-packages.R) tries to run texi2dvi which in turn
looks for /usr/bin/tex, and will fail without it. This commit adds
IUSE=test, and pulls in virtual/latex-base when it is set.

Bug: https://bugs.gentoo.org/718056
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
dev-lang/R/R-3.6.3-r1.ebuild

index 0f45bd0490e6aa7616ca420de48bb148f980004b..274948dece15b58337496144465682956e9c4099 100644 (file)
@@ -17,14 +17,17 @@ SRC_URI="
 LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="cairo doc icu java jpeg lapack minimal nls openmp perl png prefix profile readline static-libs tiff tk X"
+IUSE="cairo doc icu java jpeg lapack minimal nls openmp perl png prefix profile readline static-libs test tiff tk X"
 REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
 
+# At least one package installation in the test suite requires TeX,
+# and will fail without it (bug #718056).
 BDEPEND="virtual/pkgconfig
        doc? (
                virtual/latex-base
                dev-texlive/texlive-fontsrecommended
-       )"
+       )
+       test? ( virtual/latex-base )"
 DEPEND="
        app-arch/bzip2:0=
        app-arch/xz-utils:0=
@@ -49,7 +52,8 @@ RDEPEND="${DEPEND}
        sys-libs/zlib:0[minizip]
        java? ( >=virtual/jre-1.5 )"
 
-RESTRICT="minimal? ( test )"
+RESTRICT="minimal? ( test )
+       !test? ( test )"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.4.1-parallel.patch