app-emulation/open-vm-tools: bump to 10.1.15
authorMike Gilbert <floppym@gentoo.org>
Wed, 29 Nov 2017 23:24:17 +0000 (18:24 -0500)
committerMike Gilbert <floppym@gentoo.org>
Wed, 29 Nov 2017 23:24:47 +0000 (18:24 -0500)
Fixes build failure with rpc-less glibc.

Closes: https://bugs.gentoo.org/630522
Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7

app-emulation/open-vm-tools/Manifest
app-emulation/open-vm-tools/open-vm-tools-10.1.15.ebuild [new file with mode: 0644]

index 5a9d15bad732542e60de04bfad5f4c5005a0f498..a8bf132586f3c38ee47934399f4608028178486a 100644 (file)
@@ -1 +1,2 @@
-DIST open-vm-tools-10.1.10-6082533.tar.gz 5111726 SHA256 4632d815996e7f2c283818b0d84b0c4cf2fb82a0897d77aee0f8cbcdc5678c61 SHA512 60c52a24509cb0630f2ad649fe6717fefff624fc2a5c736ced35cbdb8f639264d482e063e8140eedb39216adfb1231d58232bfef0233ebc477ba4f9a732c5965 WHIRLPOOL a895246a9cc9d7fa664203a696b8f1c8d84bb231601f7e95c4291624b812d5504168e019cb33f9b9a64eb62baf048001c0952e54a8002bc6eb57dc0664f1d164
+DIST open-vm-tools-10.1.10-6082533.tar.gz 5111726 BLAKE2B 22e2e901c542ae14b7537bc26ff848359f30bde6824a16968b70070dd6e57c92fbf76dca0d02e35ef45bda257725e207632b0602a4336bd2d9c97d10fb094967 SHA512 60c52a24509cb0630f2ad649fe6717fefff624fc2a5c736ced35cbdb8f639264d482e063e8140eedb39216adfb1231d58232bfef0233ebc477ba4f9a732c5965
+DIST open-vm-tools-10.1.15-6677369.tar.gz 5153995 BLAKE2B 03c6b359df8f42f1ba65331dcac67e8ce86b0fce9a572c1665d3f385cae14f1757611d3948d30bb5b2e40bb2b4673bb244c45f56098faf09d6de515bb937ea3f SHA512 fe3699a7f704bdadc4c274c963d177f4700067e7436074554b7cf113ffa341ad0e4753016214f947418fd5a7cb4a6f2c0342acf074b6b414b3fd18fd2ea2bc58
diff --git a/app-emulation/open-vm-tools/open-vm-tools-10.1.15.ebuild b/app-emulation/open-vm-tools/open-vm-tools-10.1.15.ebuild
new file mode 100644 (file)
index 0000000..eb247bc
--- /dev/null
@@ -0,0 +1,156 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MODULES_OPTIONAL_USE="modules"
+
+inherit autotools flag-o-matic linux-mod pam systemd toolchain-funcs user
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="https://github.com/vmware/open-vm-tools"
+MY_P="${P}-6677369"
+SRC_URI="https://github.com/vmware/open-vm-tools/releases/download/stable-${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc grabbitmqproxy icu pam +pic vgauth xinerama"
+
+COMMON_DEPEND="
+       dev-libs/glib:2
+       dev-libs/libdnet
+       net-libs/libtirpc:0=
+       sys-fs/fuse:0
+       >=sys-process/procps-3.3.2
+       grabbitmqproxy? ( dev-libs/openssl:0 )
+       icu? ( dev-libs/icu:= )
+       pam? ( virtual/pam )
+       vgauth? (
+               dev-libs/openssl:0
+               dev-libs/xerces-c
+               dev-libs/xml-security-c
+       )
+       X? (
+               dev-cpp/gtkmm:3.0
+               x11-libs/gtk+:3
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libX11
+               x11-libs/libXcomposite
+               x11-libs/libXext
+               x11-libs/libXi
+               x11-libs/libXrender
+               x11-libs/libXrandr
+               x11-libs/libXtst
+               xinerama? ( x11-libs/libXinerama )
+       )
+"
+
+DEPEND="${COMMON_DEPEND}
+       doc? ( app-doc/doxygen )
+       net-libs/rpcsvc-proto
+       virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}/10.1.0-mount.vmhgfs.patch"
+       "${FILESDIR}/10.1.0-vgauth.patch"
+       "${FILESDIR}/10.1.0-Werror.patch"
+)
+
+pkg_setup() {
+       linux-info_get_any_version
+       local CONFIG_CHECK="~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3"
+       use X && CONFIG_CHECK+=" ~DRM_VMWGFX"
+       kernel_is -lt 3 9 || CONFIG_CHECK+=" ~VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS"
+       kernel_is -lt 3 || CONFIG_CHECK+=" ~FUSE_FS"
+       if use modules; then
+               linux-mod_pkg_setup
+       else
+               linux-info_pkg_setup
+       fi
+}
+
+src_prepare() {
+       eapply -p2 "${PATCHES[@]}"
+       eapply_user
+       eautoreconf
+}
+
+src_configure() {
+       append-cflags "$(pkg-config --cflags libtirpc)"
+       export LIBVMTOOLS_LIBADD="$(pkg-config --libs libtirpc)"
+       local myeconfargs=(
+               --disable-deploypkg
+               --disable-static
+               --disable-tests
+               --with-procps
+               --with-dnet
+               $(use_enable doc docs)
+               $(use_enable grabbitmqproxy)
+               $(use_enable vgauth)
+               $(use_enable xinerama multimon)
+               $(use_with icu)
+               $(use_with pam)
+               $(use_with pic)
+               --without-gtk2
+               --without-gtkmm
+               $(use_with X gtk3)
+               $(use_with X gtkmm3)
+               $(use_with X x)
+
+               # configure locates the kernel object directory by looking for
+               # "/lib/modules/${KERNEL_RELEASE}/build".
+               # This will fail if the user is building against an uninstalled kernel.
+               # Fixing this would mean reworking the build system.
+               $(use_with modules kernel-modules)
+               --without-root-privileges
+               --with-kernel-release="${KV_FULL}"
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       use modules && set_arch_to_kernel
+       default
+}
+
+src_install() {
+       default
+       prune_libtool_files --modules
+
+       if use pam; then
+               rm "${ED%/}"/etc/pam.d/vmtoolsd || die
+               pamd_mimic_system vmtoolsd auth account
+       fi
+
+       newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+       newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools
+       systemd_dounit "${FILESDIR}"/vmtoolsd.service
+
+       # Replace mount.vmhgfs with a wrapper
+       mv "${ED%/}"/usr/sbin/{mount.vmhgfs,hgfsmounter} || die
+       dosbin "${FILESDIR}/mount.vmhgfs"
+
+       # Make fstype = vmhgfs-fuse work in fstab
+       dosym vmhgfs-fuse /usr/bin/mount.vmhgfs-fuse
+
+       if use X; then
+               fperms 4711 /usr/bin/vmware-user-suid-wrapper
+               dobin scripts/common/vmware-xdg-detect-de
+
+               elog "To be able to use the drag'n'drop feature of VMware for file"
+               elog "exchange, please add the users to the 'vmware' group."
+       fi
+}
+
+pkg_postinst() {
+       enewgroup vmware
+       linux-mod_pkg_postinst
+}