dev-python/blinker: add python 3.7 support
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:03:21 +0000 (22:03 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:56 +0000 (22:09 -0400)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/blinker/blinker-1.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/blinker/blinker-1.4-r1.ebuild b/dev-python/blinker/blinker-1.4-r1.ebuild
new file mode 100644 (file)
index 0000000..4a04250
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="https://pythonhosted.org/blinker/ https://pypi.org/project/blinker/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+       nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( docs/html/. )
+       distutils-r1_python_install_all
+}