build-sys: simplify
authorFabian Groffen <grobian@gentoo.org>
Sun, 8 Jul 2012 17:18:30 +0000 (19:18 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sun, 8 Jul 2012 17:18:30 +0000 (19:18 +0200)
don't need all sed stuff and ignoring of .git, since we don't run this
in the top level, and hence never find a .git, second we don't want .*
stuff, so we can just use * and make our lives much easier

bin/Makefile.in
pym/Makefile.in

index bd751c986becc1391f5c6163bd2d34a5ea6dd362..9a5b59aba374a7606a456bc11a2c2469916ad40e 100644 (file)
@@ -35,18 +35,11 @@ usr_sbinprogs = \
        readpecoff \
        regenworld
 
-# This is just a lazy hack for not having to list all files individually
-# FIXME: make it a list (so it becomes explicit) and use an
-# AM_CONDITIONAL to not include the sed wrapper in it when a Prefix is
-# active.
-list_sourcedir_dirs = \
-       ( cd "$(srcdir)" && find . -name '.svn' -prune -o -type d -print )
-
 all:
 
 install:
        $(INSTALL) -d -m 755 -o "$(portageuser)" -g "$(portagegroup)" $(DESTDIR)$(PORTAGE_BIN)
-       $(list_sourcedir_dirs) | while read f ; do \
+       ( cd "$(srcdir)" && find * -type d ) | while read f ; do \
                files=( ) ; \
                for t in "$(srcdir)/$${f}"/* ; do \
                        [[ -d $${t} ]] && continue ; \
index f9a9636511f46850f6c01cb10f0206c978c64bd1..4db3a7556ddebe64abe57f3ed75f5d3a4a28992c 100644 (file)
@@ -20,7 +20,7 @@ all:
 
 install:
        $(INSTALL) -d -m 755 -o "$(portageuser)" -g "$(portagegroup)" $(DESTDIR)$(PORTAGE_PYM)
-       ( cd "$(srcdir)" && find . -name '.git' -prune -o -type d -print | sed 's|^./\?||' ) | while read f ; do \
+       ( cd "$(srcdir)" && find * -type d ) | while read f ; do \
                $(INSTALL) -d -m 755 \
                        -o "$(portageuser)" -g "$(portagegroup)" \
                        "$(DESTDIR)$(PORTAGE_PYM)/$${f}" && \