dev-php/File_Iterator: Revbump to fix autoload file
authorBrian Evans <grknight@gentoo.org>
Fri, 20 Dec 2019 18:29:38 +0000 (13:29 -0500)
committerBrian Evans <grknight@gentoo.org>
Fri, 20 Dec 2019 18:34:23 +0000 (13:34 -0500)
It was not changed to the modern namespaced classes

Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/File_Iterator/File_Iterator-2.0.2-r1.ebuild [new file with mode: 0644]
dev-php/File_Iterator/files/autoload-2.0.2.php [new file with mode: 0644]

diff --git a/dev-php/File_Iterator/File_Iterator-2.0.2-r1.ebuild b/dev-php/File_Iterator/File_Iterator-2.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..ed6e292
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="php-file-iterator"
+
+DESCRIPTION="FilterIterator implementation that filters files based on criteria"
+HOMEPAGE="https://github.com/sebastianbergmann/php-file-iterator
+       https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+       >=dev-lang/php-7.1:*"
+
+src_install() {
+       insinto /usr/share/php/File/Iterator
+       doins -r src/*
+       newins "${FILESDIR}/autoload-2.0.2.php" autoload.php
+}
+
+pkg_postinst() {
+       ewarn "This library now loads via /usr/share/php/File/Iterator/autoload.php"
+       ewarn "Please update any scripts to require the autoloader"
+}
diff --git a/dev-php/File_Iterator/files/autoload-2.0.2.php b/dev-php/File_Iterator/files/autoload-2.0.2.php
new file mode 100644 (file)
index 0000000..746fefa
--- /dev/null
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for dev-php/File_Iterator */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+    require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+    [
+               'sebastianbergmann\\fileiterator\\facade' => '/Facade.php',
+               'sebastianbergmann\\fileiterator\\factory' => '/Factory.php',
+               'sebastianbergmann\\fileiterator\\iterator' => '/Iterator.php',
+    ],
+    __DIR__
+);