www-servers/tomcat: restricted tomcat-servlet-api versions
authorMiroslav Šulc <fordfrog@gentoo.org>
Wed, 12 Feb 2020 08:59:45 +0000 (09:59 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 12 Feb 2020 08:59:45 +0000 (09:59 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-servers/tomcat/tomcat-7.0.96.ebuild
www-servers/tomcat/tomcat-7.0.99.ebuild
www-servers/tomcat/tomcat-8.5.47.ebuild
www-servers/tomcat/tomcat-9.0.27.ebuild

index 443dd981a8d0cc9fd06fbe8c7f18f8f792e893df..ad19069fd89cf65da1cf8d3fe4181c634ec60839 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,7 +24,7 @@ ECJ_SLOT="4.5"
 SAPI_SLOT="3.0"
 
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       dev-java/tomcat-servlet-api:${SAPI_SLOT}"
+       ~dev-java/tomcat-servlet-api-${PV}"
 RDEPEND="${COMMON_DEP}
        virtual/jre"
 DEPEND="${COMMON_DEP}
index 7fa74915d25f20116f1c630aa6f8e8c4260273ae..4df8f1204b9f21a6ba3cd2910d24769e064064d7 100644 (file)
@@ -24,7 +24,7 @@ ECJ_SLOT="4.5"
 SAPI_SLOT="3.0"
 
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       dev-java/tomcat-servlet-api:${SAPI_SLOT}"
+       ~dev-java/tomcat-servlet-api-${PV}"
 RDEPEND="${COMMON_DEP}
        virtual/jre"
 DEPEND="${COMMON_DEP}
index d34cd3a9d3cbec1efd19e3e657748a0a87af2d5a..729cd12dcdf169b2e16f456916f8c7954e002d2e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -24,7 +24,7 @@ ECJ_SLOT="4.5"
 SAPI_SLOT="3.1"
 
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       >=dev-java/tomcat-servlet-api-${SLOT}:${SAPI_SLOT}"
+       ~dev-java/tomcat-servlet-api-${PV}"
 RDEPEND="${COMMON_DEP}
        >=virtual/jre-1.8"
 DEPEND="${COMMON_DEP}
index 182cad35d13c1a5d31be77c2bd5a43703aa4ef80..b8e080bf0d7ebaeb74c1f2f45a73b4ed77df1c5d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -33,7 +33,7 @@ SAPI_SLOT="4.0"
 
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
        dev-java/glassfish-xmlrpc-api:0
-       dev-java/tomcat-servlet-api:${SAPI_SLOT}
+       ~dev-java/tomcat-servlet-api-${PV}
        dev-java/wsdl4j:0"
 RDEPEND="${COMMON_DEP}
        >=virtual/jre-11"