dev-python/pysnmp: Version 4.4.6.
authorJeroen Roovers <jer@gentoo.org>
Sat, 15 Sep 2018 07:48:24 +0000 (09:48 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 15 Sep 2018 07:48:24 +0000 (09:48 +0200)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-python/pysnmp/Manifest
dev-python/pysnmp/pysnmp-4.4.6.ebuild [new file with mode: 0644]

index d2809eb962e684435d9a9a7e8577bd5fa0713c83..54e3bdbc64b05bdb2319d4a0b29fc3ee40ccbddc 100644 (file)
@@ -1,2 +1,3 @@
 DIST pysnmp-4.4.4.tar.gz 436318 BLAKE2B 6e6616a79fc15d457b8da2e2260c65d9d8ef29888c033d80f2f47c8de035d0cff73dc4be1eeced8ef36dac1301b7da0d845837b780815792f545b6ad18d5496e SHA512 960ac73b7356bb236d3853432c094d3aa86a343f5e211065689e6c784293748ec6f2c1c17bf9d96b4cbe2d9d476ebbacbaff4bed7d86370e5ef61e6f03ba8c0e
 DIST pysnmp-4.4.5.tar.gz 438424 BLAKE2B db989eb9faa0d548c7e58a5e9b7127824f2798c116d27b8885b4920f5e0acf9068ea5ad88e13e8e913e24c0d21d414026f6d733cf680b41e59370c960d856197 SHA512 3164e93a8623512d903c86eebdb6f9fa5ffee29309747df4a836e257e87dc5480cf706ab527e1a8966e80c0626961f6f1b68b60cf07df2ddece305706f5445f2
+DIST pysnmp-4.4.6.tar.gz 434508 BLAKE2B 0613cd115d9b52b12a9e4ca45c0dc6b51a6e8506f5fe4d93641dd53ce61e88f4ed89783692c4220008c345179808bb4a79d4aaf1d828e072d822a0d131204fa1 SHA512 0b53fcb7d266a861b3f8dca228371a7430b5513506b4b7083e112916730cc25311cdef549373271c2da62441a603d3f33e6a1e9417dec3aac074db25fb2be7c8
diff --git a/dev-python/pysnmp/pysnmp-4.4.6.ebuild b/dev-python/pysnmp/pysnmp-4.4.6.ebuild
new file mode 100644 (file)
index 0000000..3d1c802
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="http://snmplabs.com/pysnmp/ https://pypi.org/project/pysnmp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+       >=dev-python/pyasn1-0.2.3[${PYTHON_USEDEP}]
+       dev-python/pysmi[${PYTHON_USEDEP}]
+       || (
+               dev-python/pycryptodome[${PYTHON_USEDEP}]
+               dev-python/pycrypto[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       default
+
+       if use doc; then
+               touch docs/source/conf.py
+               emake -C docs html
+       fi
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/* )
+       docinto examples
+       use examples && dodoc -r examples/* docs/mibs
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       elog "You may also be interested in the following packages: "
+       elog "dev-python/pysnmp-apps - example programs using pysnmp"
+       elog "dev-python/pysnmp-mibs - IETF and other mibs"
+       elog "dev-python/pysmi - to dump MIBs in python format"
+}