dev-util/meson: add live ebuild
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 9 Jan 2017 19:43:14 +0000 (13:43 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 9 Jan 2017 19:43:47 +0000 (13:43 -0600)
Package-Manager: portage-2.3.0

dev-util/meson/meson-9999.ebuild [new file with mode: 0644]

diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
new file mode 100644 (file)
index 0000000..f0a050e
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+if [[ ${PV} = *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+       >=dev-util/ninja-1.6.0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( authors.txt contributing.txt )