dev-python/wrapt: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:44:40 +0000 (12:44 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:48:02 +0000 (12:48 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/wrapt/Manifest
dev-python/wrapt/wrapt-1.10.11.ebuild [deleted file]
dev-python/wrapt/wrapt-1.12.0.ebuild [deleted file]

index c37e0525c7f432791181a4064b6f0edf001c10ae..1d7c552d24d24ed2814c54d41b859a76a91e3cbb 100644 (file)
@@ -1,4 +1,2 @@
-DIST wrapt-1.10.11.tar.gz 122499 BLAKE2B 1398bc84e3d5490ba6e6f6f386d5eb6439ec750a2a1c5c29acf91e87a9c9405b11ff10dcb56e4aa28d07d34f7a56fbe9154d2f30556f5a2ae4f1a0986033e05a SHA512 cc051749341bcd6fc1a950607fad94f74334a00acf0366129470181a5af7a3af32a26e5c5deee9242ee12bcc7e4c47dacb958c514aba8a764be3bcc662845b98
 DIST wrapt-1.11.2.tar.gz 124874 BLAKE2B 262518e097753830d80d834e1dcd5afe9c743e7cad8fad992146829255b99ef0c1a6d0344674935bb6beae9a8e5f42a1a4ade760f7300d104b1a17bc6f94f91f SHA512 2551247c46fbc34068e0f2d6efa91d8c87669c8bf1e16c3b5e2e5e0d84402301c38a78485b7e9a13120c99c9c942db680a84d87a52a072d530aba6444d86297d
-DIST wrapt-1.12.0.tar.gz 126524 BLAKE2B 9215b8d5b53348daaeda6a6e4141408e1ab4e6cf6112e0a152be90ed9e1040433400e8788ec48559763ab5618abab6ae601b6ed254bfd641ec1976b52071ede9 SHA512 56a88e223dfe3d1b0f5fa01219b0a9a710d5a67cacd87d8766cf122498c47a41f4e64d2fcb0d3c939bc775893a7edcac68295754819b37ca469b301f1e98df41
 DIST wrapt-1.12.1.tar.gz 126750 BLAKE2B 92aba2d400aa626445be68fdda2831132e1c341a2f20065b3d7071a2ebc174cb9de7e6a20a8375360cf7df181881fd20b7b2f70dbfdf533e8823982eeaa722f5 SHA512 33e964cb3aa2437bc7d084a98f622f7c5c8c719d97806796ae0317d35130bdb2679a9dd87be7077e2cae1eb32b65d152349fa7cc138cb392d5999cbfdcecc9ac
diff --git a/dev-python/wrapt/wrapt-1.10.11.ebuild b/dev-python/wrapt/wrapt-1.10.11.ebuild
deleted file mode 100644 (file)
index 73f3d9d..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Module for decorators, wrappers and monkey patching"
-HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
-SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND=""
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_compile() {
-       local WRAPT_EXTENSIONS=true
-
-       distutils-r1_python_compile
-}
-
-python_test() {
-       py.test -vv || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/wrapt/wrapt-1.12.0.ebuild b/dev-python/wrapt/wrapt-1.12.0.ebuild
deleted file mode 100644 (file)
index e250e36..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for decorators, wrappers and monkey patching"
-HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
-SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_compile() {
-       local WRAPT_EXTENSIONS=true
-
-       distutils-r1_python_compile
-}