Install semanage.conf since this is masked on example policy-based profiles.
authorChris PeBenito <pebenito@gentoo.org>
Sun, 8 Oct 2006 16:55:39 +0000 (16:55 +0000)
committerChris PeBenito <pebenito@gentoo.org>
Sun, 8 Oct 2006 16:55:39 +0000 (16:55 +0000)
Package-Manager: portage-2.1.2_pre2-r5

sys-libs/libsemanage/ChangeLog
sys-libs/libsemanage/files/digest-libsemanage-1.6.17-r1 [new file with mode: 0644]
sys-libs/libsemanage/libsemanage-1.6.17-r1.ebuild [new file with mode: 0644]

index 05fb07feffc020db42cecf7e1ac790251e2c420a..9984875f30cd3a5507c5e8823f99b54aa59fcc1c 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-libs/libsemanage
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.11 2006/10/05 06:23:13 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.12 2006/10/08 16:55:39 pebenito Exp $
+
+*libsemanage-1.6.17-r1 (08 Oct 2006)
+
+  08 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
+  -libsemanage-1.6.17.ebuild, +libsemanage-1.6.17-r1.ebuild:
+  Install semanage.conf since this is masked on example policy-based profiles.
 
 *libsemanage-1.6.17 (05 Oct 2006)
 
diff --git a/sys-libs/libsemanage/files/digest-libsemanage-1.6.17-r1 b/sys-libs/libsemanage/files/digest-libsemanage-1.6.17-r1
new file mode 100644 (file)
index 0000000..8959f0a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 a732f97a30c4f31a929c93dba84bbbf9 libsemanage-1.6.17.tgz 159948
+RMD160 efe598f95cc1a27e00a9d1f6d4d5ebee92fd0fcb libsemanage-1.6.17.tgz 159948
+SHA256 8b251960f6ee93ebc489092fbd8bd9e8e5648d8a8dcd3047069a754caf4390a3 libsemanage-1.6.17.tgz 159948
diff --git a/sys-libs/libsemanage/libsemanage-1.6.17-r1.ebuild b/sys-libs/libsemanage/libsemanage-1.6.17-r1.ebuild
new file mode 100644 (file)
index 0000000..486420c
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-1.6.17-r1.ebuild,v 1.1 2006/10/08 16:55:39 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+# BUGFIX_PATCH="${FILESDIR}/libsemanage-1.6.6.diff"
+
+SEPOL_VER="1.12.28"
+SELNX_VER="1.30.29"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+       =sys-libs/libselinux-${SELNX_VER}*"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+       # fix up paths for multilib
+       sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib LIBDIR failed."
+       sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+       python_version
+       emake PYLIBVER="python${PYVER}" all pywrap || die
+}
+
+src_install() {
+       python_version
+       make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap
+}
+
+pkg_postinst() {
+       python_version
+       python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+       python_version
+       python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}